Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've installed ubuntu 14.04 on my old notebook (Acer Travelmate 2420).

Everything is fine except the shutdown.

It's hanging in the last screen ("ubuntu" with the points beneath - they change their colour properly. As long as I don't press the "on/off" button of the notebook).

I've changed this line:

 GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" 

into this:

 GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=force"

it doesn't work.

Can anybody help?

I'm a ubuntu beginner, so I maybe don't understand too specific things.

share|improve this question
    
did you run update-grub after you change that line? –  JohnnyEnglish Jun 10 at 1:03
    
yes, i did. thanks. –  hns Jun 10 at 7:56
    
so you did it before I told you that? what is kernel version in your system uname -r ? –  JohnnyEnglish Jun 10 at 9:33
    
yes, i've done the things step by step as written down somewhere in the net. here is what comes, if i type "uname -r": 3.13.0-29-generic –  hns Jun 10 at 12:20
    
take a look at this askubuntu.com/questions/451791/… there's a lot of issues can be that you can find within forum –  JohnnyEnglish Jun 10 at 12:27

1 Answer 1

While you see that purple screen, you can press ESC to see exactly what Ubuntu is doing, which may be very useful if this turns out to be a bug, or if you just want to see what is taking so long.

Try going into Terminal and typing sudo shutdown -P now that ought to force Ubuntu to completely shutdown, if not then we may have to dig deeper.

share|improve this answer
    
the last 2 lines are: * Unmounting local filesystems [OK] * Will now halt –  hns Jun 10 at 12:28
    
it's still the same with: sudo shutdown -P now –  hns Jun 10 at 12:36
    
Sounds like an uncommon but not unheard of bug. I refer you here: mylinuxexplore.blogspot.com/2011/11/… In the hopes your grub is configured similarly. With any luck you may have just been missing two lines of grub args. –  agentroadkill Jun 10 at 20:45
    
after several grub-changes i decided to install a new operating system. tried lubuntu: same problem. tried ubuntu studio: everything works as far as i can see including the shutdown. so all seems to be good in the end. –  hns Jun 11 at 11:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.