Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to connect to a VPN using the NetworkManager Cisco VPN client, and everything seems to be going fine when connecting. I click connect, the NM icon on the top panel displays the connecting animation, and NotifyOSD displays the banner informing me that I've successfully connected (i.e., the VPN server displays it's welcome message), and I get a little padlock next to the wireless connection icon. Yet traffic doesn't go through the VPN. My IP address is still the same, and the ads that appear on the different websites I browse recognize my location.

However, when I connect using sudo vpnc MyVPNSettingsFile.conf from the terminal, I do it successfully here, but this time my traffic does get tunneled through the VPN. What causes this different and what can I tweak to make the NetworkManager client work? (It's not the end of the world if I have to do it through the command line, but the nm-applet integration gives me that padlock icon, and the fewer clicks take less time than opening a terminal and getting the command right.)

Thanks in advance.

share|improve this question
    
Can you provide us some log files? As far as I know you have to run ipseclog logfilename and then start vpnc. It will connect to ipseclog for the logging. –  Ruediger Apr 18 '12 at 17:43
add comment

1 Answer

hmm i don't use cisco vpn but maybe since its connected if seems strange that it doesn't work even though it claims the vpn is up.

could you compare the routing tables when connecting through terminal vs gui?

just type route -n in the terminal

if they differ paste them here.

Another thing to check , what about permissions for certificates etc? I've noticed that openvpn at least refuses to work from the applet if the permissions are to "loose" compared to if i run the vpn from the terminal

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.