Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Ubuntu installed on VMware player.

After installing the last updates the screen went like this image: enter image description here

As you see I have not real second Menu(it is not clickable)

Why did this happen and how to fix?

share|improve this question
add comment

5 Answers 5

I used my VM previous snapshot to reproduce the problem.

Previous kernel: 3.2.0-63. VM running ok.

1) I applied all updates (including openssl) but NOT the kernel. After rebooting, the VM screen is OK.

2) I updated again (only the kernel packages, version 3.2.0-64 were pending: complete kernel, headers and kernel image) and rebooted: split / doubled screen shows up!

3) I ran vmware-config-tools.pl in other to generate modules for the new kernel and rebooted: the split screen persists. Not solved.

4) also tried a full VM power off / power on: the problem persists.

It seems to be definitely a kernel 3.2.0-64 - related issue.

Suggestion: apply all updates (the openssl update is critical), but skip the kernel packages for now, until we get a fix from VMware or the Ubuntu team.

(AND: ALWAYS create a snapshot before you update anything !!)


See also these threads:

https://communities.vmware.com/message/2388587#2388587

https://communities.vmware.com/thread/481038

In summary: if you don't have a previous snapshot, either enable the grub menu on boot and choose a previous kernel (e.g. 3.2.0-63) or: using the package manager, uninstall the kernel 3.2.0-64 and RE-INSTALL the previous kernel (this will take care of grub and boot configs).

Let's wait for a fix. And don't update the kernel for now.

share|improve this answer
add comment

Confirmed - Same issue with VMWare Workstation 10.0.2 with Ubuntu 12.04 LTS.

Solved with:

sudo apt-get remove 3.2.0-64
sudo update-grub
sudo reboot
share|improve this answer
add comment

Try the answer described here :

Open System Settings > Displays. In the Displays window, you will see an Unknown monitor. Click it and disable it.

share|improve this answer
add comment

Since the 14.04LTS question was marked as a duplicate of this one, the solution for 14.04LTS is very similar.

To fix this issue on 14.04LTS I used the following:

 sudo apt-get remove 3.13.0-29-generic
 sudo update-grub
 sudo shutdown -r now

This reverted the kernel to 3.13.0-27-generic which does not exhibit the issue.

share|improve this answer
add comment

I have 14.04LTS on vmplayer, and for me help removing 3.13.0-30-generic

sudo apt-get remove 3.13.0-30-generic
sudo update-grub
sudo shutdown -r now
share|improve this answer
add comment

protected by Community Jun 24 at 7:26

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.