Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

yesterday I discovered a folder in the Trash Bin named FdtN0bhKRX containing more than 700,000 corrupted files. I know the approximate number because I tried to move the folder to a USB key, and when I cancelled the operation, the "preparing to move.." dialogue was showing that mark. The folder is 1017Mb and the files inside are all 0 byte long. I tried everything I could to remove this folder or to access it, but I failed. sudo rm or sudo su and then rm with -d and -f options goes in infinite loop, which may cause a complete block of the system's functions (including Ctrl+Alt+Del). I even coded a c++ program, which works great on other folders, but in this case it failed miserably. I searched all over the web and I couldn't find any other case like my one. The files inside the folder are named something like this:

S __FrO__ kj

I could read some of the names one of the times I tried to open the folder in Nautilus, because before the program crashed, if I clicked the back button, some of the files icons were rendered together with their name. The only command I can use on the folder is mv AFIK.

Thanks in advance for your help.

share|improve this question

2 Answers 2

This should work:

sudo rm -rf path-to-the-folder

if didn't work, do it with root privileges type sudo su press Enter and repeat the command no sudo required.

WARNING!

When login as a root, do it at your own risk! If you completely sure this folder is nothing then ok.

share|improve this answer
    
I didn't mention it because I thought it had been obvious, but I have used rm as root, too. Thanks for sharing, anyway. –  Antonio Molinaro Jun 8 at 18:23

I solved my problem with the monstrous folder which was by me found in the Trash folder. Nor the folder, nor its files had been corrupted, indeed it was a HDD Bad Blocks problem, which I detected with fsck, by running it from another partition. I'm not expert on Hard Drive, but I can say that fsck detected a problem in the folder structure (probably where the Trash folder reside on the disk).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.