Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I Re-installed ubuntu two weeks ago and at the start I could control Rhythmbox from the sound menu, but now it disappeared and i don't know how to bring it back.

In "Sound prefernces...", in the "Applications" tab, rhythmbox is shown but i can only control it's volume.

For example in the start it was something like that (but for rhythmbox): How it's supposed to be -

enter image description here

share|improve this question
    
Help please.. =\ –  Kristal Jun 11 '11 at 16:05
    
ubuntuguide.net/… may help, maybe someone can form an answer around this. –  Mateo Aug 8 '12 at 16:23

3 Answers 3

Make sure you have package rhythmbox-plugins installed. It contains MPRIS support which is vital for Sound Menu to work. After the package is installed, launch/restart Rhythmbox. Controls should appear in Sound Menu then.

You can find this package in Ubuntu Software Center:

Install via the software center

Or you can install it through terminal using this command:

sudo apt-get install rhythmbox-plugins
share|improve this answer
    
I have it and it still doesn't work =\ –  Kristal Jun 12 '11 at 15:55
    
Can you see other players like Banshee in the sound menu? –  jnv Jun 12 '11 at 16:20

Rhythmbox only shows the controls when it is running, but I'm sure you knew that.

I would try to re-install Rhythmbox:

sudo apt-get remove rhythmbox

Followed by:

sudo apt-get install rhythmbox
share|improve this answer
    
Will it erase my music library in rhythmbox? because i worked on it a lot.. –  Kristal Jun 12 '11 at 15:56
    
No, this will only reinstall the program, your personal settings will stay intact. –  jnv Jun 12 '11 at 16:20
    
Did it solved your problem? –  noinflection Jun 26 '11 at 23:41

This is probably a duplicate of question #68491. It appears that a Rhythmbox plugin ('MPRIS D-Bus interface') which is necessary for the player to communicate with the sound menu is not enabled by default on some 11.10 (and possibly earlier) installs. Kristal, please check to see if this is the case with yours. (Edit > Plugins from the Rhythmbox menu)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.