Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am fairly new to Linux in general, but I am not super dumb at it either.

I was getting tired of how Windows was always loading, so I decided to take the plunge and switch to Linux. After looking around, I installed Pinguy OS 14.04 (Ubuntu-14.04-based.) I thought the operating system was very neat, so I decided I would run some games on it. I loaded up Team Fortress 2 and gave it a shot. The FPS was... Well let's just say I decided to install the NVIDIA driver after that. I googled around and opened my terminal. I did the following command:

sudo apt-get install nvidia-current

as googling suggested. After a restart, I was left with the loading screen. I went and saw a movie and came back. And, as luck would have it, it was still at the loading screen. It hung there. After seeing this, I did Ctrl+Alt+F1 to enter a terminal. Then I did the following command:

sudo apt-get remove nvidia*

and restarted. I was greeted with the login screen and logged in. It worked! Without the driver. Frustrated, I continued searching. I ended up stumbling apon the Ubuntu Bumblebee project. I installed those, and the operating system booted fine. I went and fired up Team Fortress 2 and the FPS indicated that the driver wasn't doing anything. So I went into a terminal and typed the following command:

optirun steam

and this is what I got:

Running Steam on ubuntu 14.04 64-bit
STEAM_RUNTIME is enabled automatically

and it loaded steam normally without any performance improvments. The question is: How do I get these darn NVIDIA drivers working for my GTX 765M? I also have a i7 4700MQ with the intergrated 4600 graphics, if that matters.

If you need any logs or files or anything, just ask and I will upload them here.

share|improve this question

3 Answers 3

Login to TTY (Ctrl+Alt+F1) run:

sudo service lightdm stop

sudo apt-get purge --remove nvidia*

sudo apt-get autoremove

sudo apt-get install nvidia-current

or

sudo apt-get install nvidia-current-updates

(includes updates but current is considered to be the stable one so your choice)

sudo service lightdm restart

Login to your desktop open a terminal (Ctrl+Alt+T):

sudo nvidia-xconfig

gksudo nvidia-settings

sudo reboot

Done.

More about HybridGraphics read here

share|improve this answer

Asus GTX 780 here, I believe it uses the same drivers.

If johnnyenglish's answer doesn't work, you might have a go trying out the following.

Note that the blacklisting is necessary for me; I do NOT get anywhere without it in case of trouble.
That is as at least one of the blacklisted thingies (nouveau?) steps in - and gets something wrong; probably putting up a display somewhere that is not visible on any one of my FOUR monitors (all on the GTX 780 ports).

Note though:
This points to the latest updates which are "bleeding-edge" and may be less stable - which could be causing problems either now or further on.

Login to TTY (Ctrl+Alt+F1) and run:

# http://www.ubuntuupdates.org/ppa/xorg-edgers

sudo cat <<EOF >/etc/modprobe.d/nvidia-graphics-drivers.conf
blacklist nouveau
blacklist lbm-nouveau
blacklist nvidia-173
blacklist nvidia-96
blacklist nvidia-current
blacklist nvidia-173-updates
blacklist nvidia-96-updates
alias nvidia nvidia_current_updates
alias nouveau off
alias lbm-nouveau off
EOF

sudo stop lightdm
sudo init 3

sudo apt-get purge nvidia*
sudo add-apt-repository ppa:xorg-edgers/ppa  -y
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install nvidia-337 nvidia-graphics-drivers-337

sudo nvidia-xconfig  # creates an intial settings file
sudo nvidia-settings # keep the defaults for starters, SAVE settings.

sudo reboot
share|improve this answer
    
dpkg --list | grep nvidia should NOT show anything before you install. sudo apt-get purge nvidia* should ensure that. –  Hannu Jun 17 at 18:26

You seem to have installed Bumblebee for Hybrid graphics support (Nvidia likes to call this Optimus). The Nvidia drivers that you can install with Ubuntu come with "Primus" which basically offers support to switch between graphics cards (Intel or Nvidia).

Those two packages can clash so try to uninstall either the package nvidia-primus or Bumblebee to see if it improves things.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.