Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Xubuntu 14.04 exclusively, with Compton installed. The OS runs great and I have absolutely no screen tearing when I move my windows around, scroll in my web browser, work in Gimp or Photoshop (wine) or even when I play very graphic demanding games, like Metro Last Light, Euro Truck Driver 2 and so on. There's not a tiny bit of tearing to see, but as soon as I play videos, in xbmc, vlc or parole media player the tearing begins (strangely enough this does not apply to youtube videos). I followed all available workarounds on askubuntu and the ubuntu forum,like the 50-xserver-command.conf, startx /etc/X11/Xsession /usr/bin/xbmc-standalone -- -bs or libsdl1.2debian fix and many more, but to no avail.

I also tried the Open Source Nouveau display drivers as well, but for some odd reason they don't work so great on my system or at least with my graphics card. Even with Compton installed and configured, I have an extreme amount of screen tearing, as soon as I switch to the proprietary Nvidia drives the screen tearing is gone completely, except for the video playback with xbmc, vlc or parole media player.

System info for your reference:

OS: Xubuntu 14.04 Linux-x86_64 - Processor: Intel Core i7-4770S CPU @ 3.10GHz - Ram: 16 GB - GeForce GT 750M 1024 MB - Nvidia Driver: 331.38

Has anyone experienced such an odd issue or do you have any advice on how I could fix this?

share|improve this question
    
Did you try purging the proprietary drivers and using the open source ones instead?? –  Venki Jun 8 at 9:00
    
Yes I did, sorry I forgot to mention that in my original post.I will add it to now. –  LinuxDudester Jun 8 at 9:05
    
Its great that you are providing more information! But it would be preferable if you could add this information in your question's description itself. You can do this by pressing the edit button just below your question's tags. –  Venki Jun 8 at 9:08
    
Okay, thanks I will, sorry I am an absolute newbie.. –  LinuxDudester Jun 8 at 9:09

1 Answer 1

up vote 3 down vote accepted

There can be a lot of issues causing this problem, I know one of the solutions for Nvidia, this can be done with help of Nvidia-Settings run in terminal:

gksudo nvidia-settings

in opened screen like this check the highlighted lines:

enter image description here

Check if VBlank is activated, also you can uncheck it and watch a video then to see if it's better without, if not put it back. Usually this is the first thing stands for tearing in Nvidia graphics, navigate your mouse cursor to an option and hover the hint will pop up telling you what it does. Other issue can be with high fps percentage try to reducing quality factor.

Also in a second higlighted line GLX you can configure additional options for antialising, just hover on an option and you'll get a hint. Try configuring these two highlighted lines it should do the trick. Good Luck.

share|improve this answer
    
Thanks Johnny, that seemed to have fixed my problems. You are awesome! –  LinuxDudester Jun 9 at 0:28
    
you're welcome! –  JohnnyEnglish Jun 9 at 13:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.