Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Ubuntu 14.04 fully updated on my laptop. Since the last update every time I lock the screen (when leaving my room for example) - when I get back and input my password, it is not accepted even though it's the correct password, the error I get is:

Password incorrect, please try again

I found that clicking the "Switch Account" fixes the issue but it is very annoying, if you know any way to fix it, it would be nice. Thanks in advance

share|improve this question
    
Are the several Languages for Keyboard Layout/Input on your system? If you are not sure, I thought it is better to check if it is in different language when you are trying to log in. So rather than alt+shift(or whatever is set to change your input) you could also to jump to console CTRL+ALT+F1, type in there to check, and then come back to GUI CTRL+ALT+F7 –  Ruslan Gerasimov Jun 8 at 11:00
    
I have another language installed but the language indicator is set correctly to EN when I type in the password, jumping to console and logging into the computer using the same password works perfectly, the only way to bypass this issue as far I know is to click the Switch Account and then log in. –  Itai Ganot Jun 8 at 11:12
    
try this to reset password, psychocats.net/ubuntu/resetpassword –  ARUL Jun 16 at 7:04
    
What is the difference between resetting it as root while in multi-user session and while in single user mode? –  Itai Ganot Jun 16 at 7:11
    
Can you try if removing the other language you installed helps? Not a solution at all, but help in identifying the problem. –  i08in Jun 18 at 12:58

3 Answers 3

This isn't a direct answer, but instead of lockimg, you can use switch user screen, and set a shorcut for that.

Go to System Settings -> Keyboard -> Shortcuts -> Custom Shorcuts, then add a new one. In the "what command to be executed" line, type:

dm-tool switch-to-greeter

And then assign your chosen keypresses to it.

share|improve this answer

Try this:

sudo chown root /etc/shadow
sudo chmod u=r,g=r /etc/shadow
share|improve this answer

This procedure gives you a full root shell! You can damage your system if you are not careful!

When booting up press SHIFT and use the arrow keys to select the rescue mode option and press enter.

The file system may be read only (it is in all currently supported releases). Remount as read write

mount -rw -o remount /

This will boot the system in rescue mode and you should arrive at a prompt that looks like this

root@something

To reset your password type this in

passwd <username>

Press return, then you will be prompted to enter and confirm a new password. Once you are done resetting your password you can than switch back to the normal GUI mode by putting this in

init 2

If if appears to boot normally, but you see a message that says:

Give root password for maintenance (or type Control-D to continue): 

then you will need a different solution.

Next Option

If the "Standard Way" does not work for you and you recieve the "Give root password for maintenance" message, you can recover your password using the following steps

  1. Reboot your computer

  2. Press SHIFT or ESC at the grub prompt (as earlier).

  3. Select your image.

  4. Highlight the line that begins kernel and press 'e' to edit

  5. Go to the very end of the line, change the ro to rw and add init=/bin/bash

press enter, then press b to boot your system.

Your system will boot up to a passwordless root shell.

  1. Type in passwd username

  2. Set your password.

  3. Type in reboot

If this doesn't work I am out of suggestions.

Correction, my only other suggestion would be a clean install, but this should work.

share|improve this answer
    
I tried it just now but unfortunately it didn't solve the issue. The thing is that I can find people who are experiencing this problem across the internet but couldn't find a solution... –  Itai Ganot Jun 16 at 7:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.