Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Internet works perfectly on every other router, but browsing sucks at home (slow browsing and slow loading times). I changed DNS servers to 8.8.0.0, still doesn't help. And funnily, download speed is extremely high on this network (meaning torrents for example), but using browsers and loading websites is extremely slow (only on this network). Do I need to change something in router settings or what can I try? By the way, I use wired connection to router. Also, there's problem with the whole computer, it is much slower overall.

EDIT: There's no problem when using Windows.

EDIT:

$ ifconfig

 eth0      Link encap:Ethernet  HWaddr f2:4d:a0:c0:3f:4c  
           inet addr:192.168.11.8  Bcast:192.168.11.255  Mask:255.255.255.0
           inet6 addr: fe80::f24d:a2ff:fec6:3f4c/64 Scope:Link
           UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
           RX packets:206798 errors:0 dropped:0 overruns:0 frame:0
           TX packets:219570 errors:0 dropped:0 overruns:0 carrier:0
           collisions:0 txqueuelen:1000 
           RX bytes:76680734 (76.6 MB)  TX bytes:21738160 (21.7 MB)

 lo        Link encap:Local Loopback  
           inet addr:127.0.0.1  Mask:255.0.0.0
           inet6 addr: ::1/128 Scope:Host
           UP LOOPBACK RUNNING  MTU:65536  Metric:1
           RX packets:160 errors:0 dropped:0 overruns:0 frame:0
           TX packets:160 errors:0 dropped:0 overruns:0 carrier:0
           collisions:0 txqueuelen:0 
           RX bytes:11094 (11.0 KB)  TX bytes:11094 (11.0 KB)

$ ping -c 2 4.2.2.2

PING 4.2.2.2 (4.2.2.2) 56(84) bytes of data.

--- 4.2.2.2 ping statistics --- 
2 packets transmitted, 0 received, 100% packet loss, time 1007ms

$ ping -c 2 google.com

PING google.com (213.159.32.147) 56(84) bytes of data. 64 bytes from
lan-213-159-32-147.kns.skynet.lv (213.159.32.147): icmp_seq=1 ttl=61
time=0.936 ms 64 bytes from lan-213-159-32-147.kns.skynet.lv
(213.159.32.147): icmp_seq=2 ttl=61 time=0.937 ms

--- google.com ping statistics --- 
2 packets transmitted, 2 received, 0% packet loss, time 1001ms
rtt min/avg/max/mdev = 0.936/0.936/0.937/0.030 ms
share|improve this question
1  
What's the output of ifconfig, ping -c 2 4.2.2.2 and ping -c 2 google.com? –  Braiam Jun 9 at 21:14
    
@Braiam Interesting new information - when I go wireless it works great, but when I use wired, problems persist. Why? –  mrSuperEvening Jun 10 at 17:42
    
Something funny is going on. Why can't you ping 4.2.2.2?!?! And less than a 1ms response from google.com? Unless you're connected directly to google that's too low. Post tracepath -n google.com plus if wireless works fine everything points to ethernet, and your connection to the router –  meccooll Jun 23 at 2:01
    
If you have issues with LAN, but wireless is good, you must suspect to cable first. Didyou try another cable? –  Sencer H. Jun 27 at 11:51

3 Answers 3

Your symptoms do suggest your first DNS is invalid, so there's a timeout period, then your second DNS is able to resolve addresses correctly and you start seeing things loading.

Of course, once the connection is established, transfers are fast, as you noted.

Unless I'm missing something, 8.8.0.0 is NOT a valid DNS, which suggests this is your problem:

$ dig @8.8.0.0 yahoo.com

; <<>> DiG 9.9.5-3-Ubuntu <<>> @8.8.0.0 yahoo.com
; (1 server found)
;; global options: +cmd
;; connection timed out; no servers could be reached

If you meant to use Google DNS, the correct addresses are 8.8.8.8 and 8.8.4.4:

$ dig @8.8.8.8 yahoo.com

; <<>> DiG 9.9.5-3-Ubuntu <<>> @8.8.8.8 yahoo.com
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 32669
;; flags: qr rd ra; QUERY: 1, ANSWER: 3, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 512
;; QUESTION SECTION:
;yahoo.com.         IN  A

;; ANSWER SECTION:
yahoo.com.      1205    IN  A   98.138.253.109
yahoo.com.      1205    IN  A   98.139.183.24
yahoo.com.      1205    IN  A   206.190.36.45

;; Query time: 32 msec
;; SERVER: 8.8.8.8#53(8.8.8.8)
;; WHEN: Sat Jun 07 21:20:40 EDT 2014
;; MSG SIZE  rcvd: 86
share|improve this answer
    
Sorry, I meant 8.8.4.4, so DNS is correct. –  mrSuperEvening Jun 8 at 12:07
    
to see if it's a DNS-related problem, use dig yahoo.com to try to resolve this site. Note how long it takes, and if possible paste the entire command output here (edit your question and add it). If DNS resolution is not slow, then something else is the problem but from what you describe, that sounds like the likeliest cause. –  roadmr Jun 8 at 18:27
    
Thank you. I got the same answer as you did with dig @8.8.8.8 yahoo.com –  mrSuperEvening Jun 9 at 9:32

Your ISP is screwing with your connection. You cannot get directly to the internet as indicated by failed pings to 4.2.2.2 Then PING google.com (213.159.32.147) shows that your ISP is redirecting your DNS 213.159.32.147 is NOT google's IP but belongs tolan-213-159-32-147.vln.skynet.lt which is probably your router or local proxy/cache because latency is so low less than 1ms. So when you think you're pinging google, you're actually pinging some proxy owned by skynet.lv It's not a satellite internet is it? You might have a "fat pipe" can get a lot of data at a time (that would explain fast torrents and big file downloads) but high latency (meaning it takes a while for a packet to reach it's destination). So your big files download would seem "fast" but browsing VOiP and other activities that don't require much data but need fast response would seem slow. try ping -c 2 ir1.fp.vip.gq1.yahoo.com or some other odd domain you never visited and look at the time if it's > 100ms that would be your problem if it's < 3ms then it's your ISPs server. You can also try tracepath somedomain.com

share|improve this answer

You're probably on the right track to specify a name server. The one you choose (8.8.0.0) doesn't resolve, and would end up adding lookup time to your browsing. Try specifying (8.8.8.8) instead.

Also try using the resolveconf's header file function so that you can leave all the other default's from your dhcp untouched and just add a nameserver header.

Update your /etc/resolvconf/resolv.conf.d/head to:

# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN


nameserver 8.8.8.8

By the way, I don't know why the file defaults to saying do not edit by hand. I believe the purpose of the file is to edit by hand. It's really the /etc/resolv.conf file that is overwritten.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.