Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to completely remove some of the applications, using Synaptic Package Manager, that I have uninstalled in Ubuntu 11.04. I'm pretty sure I am doing everything correctly. I check the application as "mark for complete removal," but the Apply button stays unclickbable. I also tried 'sudo apt-get purge (application)', and that isn't doing it either. Is this a bug or what?

share|improve this question
what does using 'apt-get purge' report? – thomas michael wallace Jun 9 '11 at 19:24
did you try sudo aptitude remove --purge <package>? – Thomas Ward Jun 9 '11 at 19:27
@thomas micheal wallace It says The following packages will be REMOVED: kmetronome* 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. But the application is still in the "residual config" section of Synaptic. Is this just a bug? @EvilPheonix Yep. – Steven Jun 9 '11 at 19:30
I have the same problem, and filed a "Bug" for it a couple of weeks ago. Haven't heard anything back about it yet. – Rob Jun 10 '11 at 1:47
up vote 3 down vote accepted

this has just worked for me:

sudo dpkg --purge [package name]
share|improve this answer
Yes! It worked! Thank you! It's been driving me insane lol. – Steven Jun 10 '11 at 3:55
sudo apt-get remove <package_name>

This command removes an installed package, leaving configuration files intact.

sudo apt-get purge <package_name>

This command completely removes a package and the associated configuration files. Configuration files residing in ~ are not usually affected by this command.

sudo apt-get autoremove

This command removes packages that were installed by other packages and are no longer needed.

share|improve this answer
I tried those but in Synaptic all my uninstalled applications are still in the residual config section. It only started doing that recently. They usually all disappear when I use those commands. Do you think maybe it's just a bug? – Steven Jun 9 '11 at 19:40

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.