Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So my gVim has this annoying bottom border:

fat border gvim

I wish it didn't and looked more like gnome-terminal for example:

pretty gnome-terminal

Is there any way for gVim to look like that?

UPDATE: There is! Here's a screenshot after adding settings from Jeremy Cantarell's and my own answer:

epilogue

share|improve this question
add comment

3 Answers

up vote 4 down vote accepted

This is what I use to get rid of the resize handle in the corner. Just put this in ~/.gtkrc-2.0

style "no-resize-handle"
{
    GtkWindow::resize-grip-height = 0
    GtkWindow::resize-grip-width = 0
}

class "GtkWidget" style "no-resize-handle"
share|improve this answer
    
This was it, thanks a lot! –  miloshadzic Jun 10 '11 at 0:05
add comment

Ok so setting this in my .gtkrc-2.0 alleviates the problem:

style "vimfix" {
  bg[NORMAL] = "#242424" # this matches my gvim theme 'Normal' bg color.
}
widget "vim-main-window.*GtkForm" style "vimfix"

Screenshot:

Border is the same color as vim's Normal bg

This still doesn't fix the resize triangle in the lower right.

share|improve this answer
    
This worked for me too in 13.04, but I had to create .gtkrc-2.0 since it didn't exist yet. –  Cory Klein Sep 30 '13 at 22:36
add comment

It looks like you have a blank line in your statusline format codes. Can you tell us what ":set statusline" shows? Maybe we can help you format another one, or you can set to something simple yourself, or turn it off altogether.

share|improve this answer
    
I don't think that's the issue. Even if I change the statusline, the light grey border on the bottom still remains along with the grey resize thingy. –  miloshadzic Jun 9 '11 at 13:08
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.