Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a vaio laptop and it used to have installed windows 8 and Xubuntu 13.04 in dual boot, everything was working fine.

I decided to update my version of xubuntu 14.04 LTS mainly because the support for 13.04 is finished and LTS version have 3 years of support. What I did was to format the partition where xubuntu 13.04 was installed and install 14.04 in that formated partition. When I restarted my computer willing to start using my new system I got the following message:

error: symbol 'grub_term_highlight_color' not found

and I was not able to enter any OS.

I tried boot-repair from live USB more than two times and it did not fix the problem.

I tried to enter to my computer using super GRUB2 disk, however it does not apperar to work with UEFI active (besides super grub2 disk says it can) I only get the message "no operating system found".

If I boot super grub2 disk with UEFI disabled, super grub2 disk can not detect any OS,I also tried Rescatux distro, however, as of super grub2 disk, rescatux cannot enter when UEFI is active.

I tried boot-repair with the option of "restore EFI backups", after that I was able to boot on windows, but no grub menu appeared. I ran boot-repair again with no improving results

Here is the last Bootinfo report I got:

http://paste.ubuntu.com/7609801/

Do you have any idea of what is happening?

I really appreciate your help,

Best regards,

Update

Hi and thanks for your suggestions.

I was able to enter my different OSes using rEFInd (secure boot disabled), however, after different tries I was not able to get a boot menu (either GRUB or rEFInd) to select an OS :(

I tried to install rEFInd in my hard disk, however, when booting it goes directly to windows.

I tried again boot repair, nothing happen.

I tried dpkg-reconfigure, nothing happen.

Here is the last bootinfo summary I got.

http://paste.ubuntu.com/7651147/

The only way for now to enter Xubuntu in my computer is using rEFInd USB with secure boot disabled.

Thanks for your help,

Any comment is appreciated

share|improve this question

2 Answers 2

See this bug report: Ubuntu 14.04 Update breaks grub, resulting in "error: symbol 'grub_term_highlight_color' not found"

https://bugs.launchpad.net/ubuntu/+source/grub2/+bug/1289977

You need to chroot & use dpkg-reconfigure grub-pc instead of grub-install directly, so that the system knows that it needs to run grub-install on that drive the next time grub is upgraded.

Boot-Repair has a chroot total uninstall and reinstall of grub, which may work or while in chroot run the dpkg update.

share|improve this answer
1  
Do not install grub-pc on the system in question; that computer uses EFI, and grub-pc is the BIOS-mode version of GRUB. It's conceivable that something similar with grub-efi-amd64 would work, but I've not tested that. See my own answer for an alternative. –  Rod Smith Jun 9 at 1:37

I can't say much about a fix involving GRUB. (I've never much cared for GRUB 2, and I try to avoid it as much as possible.) I do have an alternative, though:

  1. Enter the firmware and disable Secure Boot. (You can re-enable it later if you like, but it's easiest to turn it off for now.)
  2. Prepare a USB flash drive or CD-R with the appropriate image of my rEFInd boot manager.
  3. Boot to rEFInd. You should see at least one option for Windows and at least one option for Ubuntu.
  4. Test the rEFInd boot options. It's OK if some don't work, so long as you can get into both Windows and Ubuntu. If not, stop and report back or try another approach.
  5. If you can boot both Ubuntu and Windows, boot to Ubuntu and install rEFInd there. You can use the Debian-package download link near the top of the downloads page or use the PPA described later on that page.

When you reboot, you'll be brought into rEFInd and should be able to boot both OSes, bypassing GRUB. If you've got stray entries, you can remove them by deleting files or by editing the /boot/efi/EFI/refind/refind.conf file: Uncomment the dont_scan_dirs or dont_scan_files line and adjust the values to blacklist the unwanted entries. If you disabled Secure Boot but want it active, you may be able to enable it at this point, although you may have to register the refind.cer or refind_local.cer key (a program to do so should launch when you reactivate Secure Boot and reboot; the file should be in the EFI\refind\keys directory on the ESP). That said, Secure Boot can be a bit hairy, and you may need to jump through some more hoops to use it.

share|improve this answer
    
I was able to enter my different OSes using rEFInd (secure boot disabled), however, after different tries I was not able to get a boot menu (either GRUB or rEFInd) to select an OS :( I tried to install rEFInd in my hard disk, however, when booting it goes directly to windows. I tried again boot repair, nothing happen. I tried dpkg-reconfigure, nothing happen. Here is the last bootinfo summary I got. paste.ubuntu.com/7651147 The only way for now to enter Xubuntu in my computer is using rEFInd USB with secure boot disabled. Thanks for your help, Any comment is appreciated –  h3bm Jun 16 at 12:30
    
There's no evidence of a rEFInd install on your hard disk. I recommend you try again. If necessary, follow the manual installation instructions and, if any errors crop up, post details. –  Rod Smith Jun 16 at 12:48
    
Hi Rod, I removed rEFInd after I saw it didn't work. I installed again, and didn't work. When I turn on the computer it boots directly in Windows. Here is the boot info summary paste.ubuntu.com/7660764 I don't know if there is any additional configuration needed. I tried removing the file /boot/efi/EFI/Microsoft/Boot/bootmgfw.efi when I did it GRUB starts ok, but I wasn't be able to enter Windows that way. Thanks for your help –  h3bm Jun 17 at 22:52
    
In Windows, try opening an Administrator command prompt window and typing bcdedit /set {bootmgr} path \EFI\refind\shimx64.efi. When you reboot, you may need to locate rEFInd's key file. If you still boot straight to Windows, try updating your firmware and try again with bcdedit. If that fails and the computer is still within the return period, return it for a refund, because your firmware is broken. If that's not an option, look into alternative naming options for rEFInd (or GRUB). –  Rod Smith Jun 18 at 12:17
    
Within Windows I use bcdedit program > bcdedit /set {bootmgr} path /EFI/ubuntu/grubx64.efi After reboot I went straight to Windows. So I tried the alternative naming options. I changed the file bootmgfw.efi from /EFI/Microsoft/Boot/ to /EFI/Microsoft/ and copied grubx64.efi to /EFI/Microsoft/Boot/ and rename it to bootmgfw.efi. However when reboot it goes directly to Windows. –  h3bm Jun 23 at 2:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.