Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I run a rsync to backup my home folder over the network like so:

rsync -avhz --progress --delete /home/dbdean/ david@tv.local:/home/backups/david/

I seem to have problems with my quite large .VirtualBox/HardDisks/Windows XP.vdi file. Occasionally the wifi will silently fail (the transfer stops, and any other network access is broken). If I reconnect the wifi to my network before the transfer times out, it happily keeps going (and other network access is back), but I can't just leave it unattended most of the time, as I have to keep an eye on it.

I'm guessing this is probably a bug in the wireless card related to a particularly high sustained volume of network usage, but I'm not really sure where to start with diagnosing this problem so that I can provide a good bug report. Or it could be something else, I guess. Any help would be appreciated.

My network card is an Atheros Communications Inc. AR9285, as lspci -k shows:

43:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
    Subsystem: Hewlett-Packard Company Device 3040
    Kernel driver in use: ath9k
    Kernel modules: ath9k
share|improve this question
    
Are you sure it isn't the wireless router that is dropping the connection? Have you checked the logs? –  user19585 Jun 9 '11 at 11:31
    
yeah, because reconnecting the wireless on the laptop fixes it, and no-one else loses access. –  David Dean Jun 9 '11 at 11:59
    
What kind of wifi card (try lspci | grep Ethernet)? I'm seeing this with an Atheros AR9285 card (in a laptop). –  Adam Monsen Jun 20 '11 at 9:00
add comment

2 Answers 2

up vote 2 down vote accepted

Are you using an Atheros wifi card on Natty? If so, try upgrading your Linux kernel to 2.6.39. See my answer on Wireless on an Atheros AR9285 is slow and disconnects for more information.

share|improve this answer
    
I am. I'll have a go at upgrading my kernel and give you a tick if it fixes it. Thanks! –  David Dean Jun 21 '11 at 5:06
    
It seems you are right. Kernel 2.6.39 fixes the problem. –  David Dean Jun 21 '11 at 13:16
    
David Dean: right on! Will you also consider trying out 2.6.38-10.44? –  Adam Monsen Jun 21 '11 at 17:01
add comment

I think because rsync use all bandwidth in wifi CMIIW, you must limit rsync banwidth usage so other proccess still work. try to add --bwlimit parameter, then your script will be like this :

rsync -avhz --bwlimit 10 --progress --delete /home/dbdean/ david@tv.local:/home/backups/david/

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.