Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Launchpad bug #794975

I have a nVidia GeForce 8600 GT video card. I'm not using closed source drivers (so I'm using what ever the default ubuntu/linux drivers are). I have 2 monitors plugged in the back of them. Both monitors worked out of the box with no extra settings needed. Today I upgraded to Ubuntu 11.04 and the dual monitors don't work. only one monitor works.

Here's some hardware information

$ sudo lshw -C display
       description: VGA compatible controller
       product: G84 [GeForce 8600 GT]
       vendor: nVidia Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
       configuration: driver=nvidia latency=0
       resources: irq:16 memory:f2000000-f2ffffff memory:e0000000-efffffff memory:f0000000-f1ffffff ioport:1100(size=128)


$ lspci -nn | grep VGA
01:00.0 VGA compatible controller [0300]: nVidia Corporation G84 [GeForce 8600 GT] [10de:0402] (rev a1)


$ xrandr 
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 320 x 240, current 1280 x 1024, maximum 1280 x 1024
default connected 1280x1024+0+0 0mm x 0mm
   1280x1024      50.0*    51.0  
   1280x960       52.0  
   1152x864       53.0     54.0     55.0     56.0  
   1024x768       57.0     58.0     59.0  
   960x600        60.0  
   960x540        61.0  
   840x525        62.0     63.0     64.0     65.0  
   832x624        66.0  
   800x600        67.0     68.0     69.0     70.0  
   720x450        71.0  
   700x525        72.0     73.0  
   680x384        74.0     75.0  
   640x480        76.0     77.0     78.0     79.0     80.0  
   512x384        81.0     82.0  
   400x300        83.0  
   320x240        84.0     85.0  
share|improve this question

Actually I had it wrong. I was using the closed source drivers. I found out when I greped for nvidia in dmesg. I apt-get removed that package (think it was nvidia-current), and rebooted and everything works now.

share|improve this answer
If this is the best answer you should accept it even if it's your own. – N.N. Aug 26 '11 at 22:12

have you ever try third party driver/application, Sometimes help us when we use giant screen and multiple monitor. this is application what i mean :

  • Xinerama (open source and binary driver)
  • nVidia-only TwinView (binary driver)
  • ATI, Matrox MergedFB (open source driver)
  • ATI-only BigDesktop (binary driver)

All options above perform the same function. However, because of the variations of graphics cards in the market and sometimes give various result. check this, hopefully can help.

share|improve this answer

Type this in Terminal and see :

sudo xrandr --auto

It probes the monitor for supported refresh rates and resolutions and attempts to auto-configure the graphics card to work with the monitor.

share|improve this answer
Please add more description to what this command will do. It's not safe to just type in random sudo commands. – Thomas Boxley Sep 28 '11 at 0:41

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.