Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This has been asked before but there is no answer that works for me. The last answer I saw said to use System Settings. If I look there (Details, Default applications, Web), it says that Chrome IS my default browser. But every time I launch Chrome, it asks me again. If I look within Chrome under Settings, Default Browser, it says that it is not the default browser. There is a large button marked "Make Google Chrome the default browser" but, as someone else as already reported, this button has no effect. I am on the stable channel for Chrome. I tried making a comment to the existing thread but was unable to. That is why I am asking as a new question.

share|improve this question
    
when you set Chrome in system settings > details as default it be default, it will not appear in browser settings though. –  JohnnyEnglish Jun 7 at 14:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.