Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I downloaded Ubuntu 14.04 today, and I went about installing it on my personal laptop. During the installation it asks you if you would like to apply updates while the installation is being processed; however, my laptop was already having issues connecting at the time, so I could not select that option. (I do not know if that has any effect on the issue I am currently experiencing.)

Ubuntu just finished installing, and it automatically has no connections. I plugged in an ethernet cord to the laptop, and I still couldn't get any sort of connections.

Any help would be greatly appreciated.

Note: Before installing Ubuntu, I was running Windows 7. I was, also, connected to WiFi earlier today, before installing Ubuntu.

share|improve this question

The first thing that I would check is whether or not your network adapters are even detected by Ubuntu. When you look at your notification bar, do you see a network connection applet? It looks like what I've circled in yellow on this graphic:

Screenshot #1: https://drive.google.com/file/d/0BxrzKpGlppKUcWFmU1RFUkx4TU0/edit?usp=sharing

After clicking on that you should see an option that says "Edit connections..." When you click on that you should see one or two network adapters, depending on what your computer has and what Ubuntu is detecting. See the screenshot below for a sample image.

Screenshot #2: https://drive.google.com/file/d/0BxrzKpGlppKUWVpGRDhHdGR5SEU/edit?usp=sharing

If you see one labeled wired connection, that's the one I would start off with first. It should be configured to get a dynamic IP address. Assuming that the router you're plugging it into is also a DHCP server, or that you have a separate DHCP server running on your network.

As far as you're wireless connection is concerned, if Ubuntu is detecting your wireless adapter you should be able to see all of the available wireless networks in your area. They are visible to you when you click on the network connection applet in my first screenshot. If you don't see your wireless network, you click on the option to "Connect to Hidden WiFi Network".

share|improve this answer

NIC Solution for Dell Latitude E4200 Running Ubuntu 14.04.3

In short:

  1. Apply updates
  2. Go to System Settings
  3. Software Updates
  4. Select "Additional Drivers"
  5. Select "Using Broadcom 801.11 Linux..." Under Broadcom Corp Wireless 1397..
  6. Reboot

and Voilà: it works!

share|improve this answer

http://packages.ubuntu.com/precise/all/linux-firmware-nonfree/download

download a deb file from any link, double click the deb file on your linux system, then it will install the linux-firmware-nonfree

It worked for me when even wire connection is not working on my computer.

share|improve this answer

Had this problem myself after installing 14.04.

Make sure the wireless switch is on. On the Dell Latitude D630 it's on the left side, a few inches from the front (I don't know if it's the same on 131L).

Connect to the internet via Ethernet, open a terminal, and issue these commands:

sudo apt-get remove --purge ndiswrapper*
sudo apt-get remove --purge bcmwl-kernel-source
sudo apt-get install firmware-b43-installer

Then reboot.

This worked for me.

Source: Dell Latitude D630 wireless issues running Ubuntu 13.10

You also asked about not having been connected to the internet while installing. I recommend running sudo apt-get install ubuntu-restricted-extras. I'm pretty sure this is what would have been installed had you been online during install (not positive).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.