Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I don't want my desktop session wallpaper to be used as lockscreen background.

Thank you

share|improve this question

2 Answers 2

If you mean the Login Screen you can change it for example with help of Ubuntu-Tweak

sudo apt-add-repository ppa:tualatrix/ppa
sudo apt-get update
sudo apt-get install ubuntu-tweak

Open Ubuntu-Tweak from Dash navigate to Tweaks > Login Settings click unlock enter your sudo password and change it with desired wallpaper.

For more look here

share|improve this answer
    
Not at all: as I said, I meant lockscreen. I already set the login screen background with ubuntu-tweak and I'd like to set the same picture for the locked screen. In dconf I tried to set org.gnome.desktop.screensaver.picture-uri to /usr/share/backgrounds/Trusty.jpg but this doesn't work (I didn't reboot yet). –  useful Jun 7 at 7:37
    
please check my edited answer. –  JohnnyEnglish Jun 7 at 7:44
    
also read this: askubuntu.com/questions/42166/… –  JohnnyEnglish Jun 7 at 7:50
    
Thank you Johnny, light locker seems to be the way to do it. It is not installed in my Trusty, maybe because I upgraded 1304->1310->1404. I will now dig further to find if this package is the new default for Ubuntu desktop. bye-bye –  useful Jun 7 at 13:00
    
it's available for trusty packages.ubuntu.com/… –  JohnnyEnglish Jun 7 at 13:06
up vote 0 down vote accepted

Found a per user setting : launch dconf-editor then untick com.canonical.unity-greeter draw-user-backgrounds.

For a system wide setting the way is the same as for disabling greeter to use wallpapers and setting a common one from /usr/share/backgrounds:

Set a background with Ubuntu-tweak or

sudo -i
su lightdm -s /bin/bash
gsettings set com.canonical.unity-greeter background '/usr/share/backgrounds/MyTrusty.jpg'
gsettings set com.canonical.unity-greeter draw-user-backgrounds 'false'
share|improve this answer
    
I also found a page here askubuntu.com/questions/313526/… were they use a slightly difference in commands: they add xhost +SI:localuser:lightdm just after issuing sudo -i –  useful Jun 10 at 14:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.