Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently purchased a laptop with an Nvidia GeForce 860m, and have installed Ubuntu 14.04. On my old laptop I had 12.04, which automatically filled Additional Drivers with Nvidia drivers. But on this computer, the only thing in Additional Drivers is Qualcomm. So I manually installed Nvidia, but X Server Settings doesn't seem to detect any GPU...

lspci | grep VGA reports only my integrated Intel GPU, but

lspci -v reports many things, including the Nvidia GPU:

01:00.0 3D controller: NVIDIA Corporation GM107M [GeForce GTX 860M] (rev a2)
Subsystem: ASUSTeK Computer Inc. Device 157d
Flags: fast devsel, IRQ 16
Memory at ec000000 (32-bit, non-prefetchable) [size=16M]
Memory at c0000000 (64-bit, prefetchable) [size=256M]
Memory at d0000000 (64-bit, prefetchable) [size=32M]
I/O ports at e000 [size=128]
Expansion ROM at ed000000 [disabled] [size=512K]
Capabilities: access denied

Don't know what any of that means. Not sure if it's supposed to say 'access denied'...

I need my GPU to do CUDA and OpenGL programming. What else can I do to figure out why this isn't working?

EDIT: per request, the contents of xorg.conf :

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 304.117  (buildmeister@swio-display-x86-rhel47-01)  Tue Nov 26 22:29:40 PST 2013


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
share|improve this question
    
does gksudo nvidia-settings show your GPU? You mean it's not listed in xorg.conf? what is the version of nvidia driver installed in the system? you can see this also from nvidia-settings. –  JohnnyEnglish Jun 6 at 21:28
    
add also info from sudo gedit /etc/X11/xorg.conf for Section "Device" –  JohnnyEnglish Jun 6 at 21:35
    
gksudo nvidia-settings and nvidia-settings both take me to Nvidia X-Server Settings, which does not recognize that I have a GPU. Most of the tabs that are supposed to be there when you have a GPU are not present. xorg.conf is completely empty. –  user258887 Jun 7 at 0:53
    
you should run sudo nvidia-xconfig to create a valid xorg.conf for your video card. –  JohnnyEnglish Jun 7 at 1:01
    
read this askubuntu.com/questions/66328/… –  JohnnyEnglish Jun 7 at 1:03

1 Answer 1

up vote 0 down vote accepted

It was fixed by installing nVidia driver version 331:

sudo apt-get purge nvidia*
sudo apt-get install nvidia-331-updates-dev

Then installing bumblebee per the instructions here:

sudo apt-get install bumblebee bumblebee-nvidia primus

After a reboot, I was able to use my nVidia gpu for specific programs by using the 'optirun' command. :)

share|improve this answer
    
But now my OpenGL version seems to be acting like pre-2.0, even though glxinfo says I have version 3. I will be posting another question about this. –  user258887 Jun 29 at 2:28
    
Question posted at askubuntu.com/questions/489434/… –  user258887 Jun 29 at 2:46
    
Didn't worked for me. I tried multiple divers and non seems to work. –  tikend Sep 6 at 13:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.