Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running VirtualBox 4.3.12 on MacBook Pro 15.4" with OSX 10.9.3. Inside VirtualBox I have Ubuntu 14.04 (upgraded from 13.10).

I'm almost sure, that 3D Acceleration stopped working after VirtualBox upgrade from 4.3.10 version, but it also may be upgrade to 14.04 (or one of the following packages upgrade).

I've following directions from this answer several times, but no luck. Output still says that 3D Acceleration is not enabled:

$ /usr/lib/nux/unity_support_test -p
OpenGL vendor string:   VMware, Inc.
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.4, 128 bits)
OpenGL version string:  2.1 Mesa 10.1.3

Not software rendered:    no
Not blacklisted:          yes
GLX fbconfig:             yes
GLX texture from pixmap:  yes
GL npot or rect textures: yes
GL vertex program:        yes
GL fragment program:      yes
GL vertex buffer object:  yes
GL framebuffer object:    yes
GL version is 1.4+:       yes

Unity 3D supported:       no

I found bug #12941 in VirtualBox Bug Tracker, but seems it isn't my case since I don't have any openGL errors.

Any ideas how to handle this?

share|improve this question

closed as off-topic by Braiam, chaskes, bain, Eliah Kagan, Seth Jun 25 at 4:47

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems with the development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – Braiam, chaskes, bain, Eliah Kagan, Seth
If this question can be reworded to fit the rules in the help center, please edit the question.

1  
just in case: did you re-install the guest additions after the release upgrade? –  Takkat Jun 6 at 18:19
    
Yes, I did it several times. –  devoto13 Jun 7 at 7:20
    
I would recommend to fill a new bug report with upstream. –  Braiam Jun 24 at 2:53
    
Well, closing this question is NOT that helpful. According to blogs.oracle.com/fatbloke/entry/… there seems to be a race condition in kernel module loading (unsure if this is a Ubuntu bug). Try the following: sudo bash -c 'echo vboxvideo >> /etc/modules' –  aanno Jul 1 at 6:59
    
@aanno, accepted answer works for me, so I have closed this question. Blog post is published about a year ago, also your suggestion is a part of the directions, which I linked in my question. –  devoto13 Jul 2 at 17:55

2 Answers 2

up vote 8 down vote accepted

I had the exact same issue except that I run VirtualBox 4.3.12r93733 on a Windows 7 host, not OSX.

After trying many different things without success, I had a look at the linked VirtualBox bug report which claimed "fixed as of 27 May 2014 in VirtualBox 4.3.x and later releases".

The very last comment (as of today) has a link to a recent CD image for the VirtualBox Guest Additions.

After installing this in my 14.04 guest, the command line

/usr/lib/nux/unity_support_test -p

finally reports

Unity 3D supported: yes

and all the Unity window animations are smooth as butter.

Update 2014-07-20:

According to the latest comments on this answer, there is no need for downloading the CD image any more, as it has finally become part of the official VirtualBox distribution. So if you upgrade, you'll get the fixed Guest Additions.

If you're stuck with a VirtualBox version without the fixed Guest Additions, you can get the CD images from the VirtualBox download repository - just find the correct version's folder and get the VBoxGuestAdditions_*.iso file inside it.

share|improve this answer
1  
Fixed it for me. Apparently the ISO file is periodically updated. This is the current one, although it'll probably only be good for a short time: virtualbox.org/download/testcase/… –  bmaupin Jul 15 at 15:12
    
@bmaupin: Thanks for the update. I am wondering when these guest additions with the fix will be finally included in the main VirtualBox download. Seems like they're still "test cases"... I therefore also find it a little funny that they claim "fixed as of 27 May 2014". Ah well, at least we have a workaround. –  FriendFX Jul 16 at 0:51
2  
Both links are dead already. Look for the newest ISO here: download.virtualbox.org/virtualbox (currently 4.3.14). Fixed 3D in virtualbox for me :) –  wwwhizz Jul 18 at 13:56
    
@wwwhizz Thanks for the update. Is that the official download repository? Are the Guest Additions still not part of the main download? And did you just find the latest folder in that directory and download the image from there? –  FriendFX Jul 19 at 13:26
1  
@FriendFX Yes, that is the official download repository, and yes that's indeed what I did. I've just checked, and the ISO is included in the official host-application as well, so updating VirtualBox on your host machine would do the trick as well: oracle.com/technetwork/server-storage/virtualbox/downloads/… –  wwwhizz Jul 19 at 13:56

If you haven't enabled 3D acceleration with VirtualBox settings themselves, use this.

Go to the settings of the VirtualBox that Ubuntu is running in, click Video, and click enable 3d acceleration.

share|improve this answer
1  
This tickbox is enabled. –  devoto13 Jun 6 at 17:05

Not the answer you're looking for? Browse other questions tagged or ask your own question.