Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

as mentioned in the title, I'm no longer able to load Ubuntu with the proprietary NVIDIA drivers since the update to kernel 3.13.0-27 and it is still not working for 29. The nouveau drivers work fine, but as I'm using CUDA for some applications it won't do. I tried to reinstall the drivers on several occasions (with sudo apt-get purge nvidia*) but I always boot into the low graphics mode of the login screen and after login unity won't load.

I'm using nvidia-331-updates but also tried different versions, but all of them gave me the same results. Everything worked fine before the update and even after the update, until 3.13.0-29 I was able to load the drivers by starting with the 3.14.0-24 kernel. This, however, stopped working today with another update. I've also tried to re-install ubuntu-desktop and unity with no change in result. I've got an NVIDIA GTX 570. Any ideas?

Here's the output of lspci -nnk | grep -iA2 VGA (after removing the nvidia drivers):

VGA compatible controller [0300]: NVIDIA Corporation GF110 [GeForce GTX 570 Rev. 2] [10de:1086] (rev a1)
Subsystem: NVIDIA Corporation Device [10de:0871]
Kernel driver in use: nouveau

And here the output of grep -e '(EE)' /var/log/Xorg.0.log

(EE) Failed to load module "nvidia" (module does not exist, 0)
[    19.612] (EE) Failed to load module "nvidia" (module does not exist, 0)
[    19.652] (EE) [drm] KMS not enabled
[    19.652] (EE) [drm] KMS not enabled
[    19.652] (EE) open /dev/dri/card0: No such file or directory
[    19.652] (EE) open /dev/dri/card0: No such file or directory
[    19.652] (EE) open /dev/dri/card0: No such file or directory
[    19.652] (EE) open /dev/dri/card0: No such file or directory
[    19.667] (EE) Screen 0 deleted because of no matching config section.
[    19.667] (EE) Screen 0 deleted because of no matching config section.
[    19.700] (EE) FBDEV(0): FBIOBLANK: Invalid argument
[    19.735] (EE) AIGLX: reverting to software rendering
[    20.383] (EE) FBDEV(0): FBIOBLANK: Invalid argument
share|improve this question
    
are you using proprietary driver from Ubuntu repos or manually installed? –  JohnnyEnglish Jun 6 at 22:02
    
I'm using the one from the repos. –  Norak Jun 7 at 6:42
    
please add the output lspci -nnk | grep -iA2 VGA –  JohnnyEnglish Jun 7 at 6:47
    
did you try to re-install the driver? –  JohnnyEnglish Jun 7 at 7:22
    
I've re-installed it several times. I'll post the output as soon as I'll get back to the PC. –  Norak Jun 7 at 14:50

1 Answer 1

up vote -1 down vote accepted

I finally figured out the problem and I'm not sure whether this is a bug or a feature.

Because I'm using the CUDA compiler I used update-alternatives to set gcc 4.4 as my default compiler. However, since the latest kernel updates, the nvidia drivers fail to build if the default compiler is set to a different version while the kernel is build with 4.8. When trying to manually installing the official nvidia drivers without dkms (which alway failed) I finally got an error message that pointed me into the right direction.

Setting back the default gcc to 4.8 solved my problem and I was able to install the driver both from the repo and from the nvidia site. This one was tough to figure out because there were no error messages whatsoever during the installation of the drivers from the repos!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.