Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently installed Ubuntu Natty (11.04) and now pressing Alt+Left/Right arrow key switches my tty to the adjacent one. How can I reconfigure the keyboard shortcuts so that this stops happening?

Update: I enabled Ctrl-Alt-Backspace restarting X. Now when I start my computer and then restart X, this problem stops occurring. However, if I don't restart X after starting my computer, this problem persists.

Another update: reinstalling the system fixed the problem.

share|improve this question
really? your tty? not your desktop workspace? – con-f-use Jun 9 '11 at 7:48
Yes, my tty. It also causes the Alt-Left/Right key combination to be applied to the tty I'm in. So if I'm browsing, then Alt-Left will switch my tty to the previous one and when I switch back, the browser has also gone back to the previous page. No idea why it's that way and googling didn't seem to indicate that anyone else was facing this issue either. There must be some configuration file that controls the shortcut though... – Sid Jun 9 '11 at 8:21
Sid, I observe the same behaviour, and it is particularly annoying when you're in X. I wonder what the problem is... – brice Jul 12 '11 at 14:33
@brice, what does xmodmap -pke | grep Left (in a terminal) tell you? – taneli Aug 11 '11 at 13:28
@taneli: (keycode 23 = Tab ISO_Left_Tab Tab ISO_Left_Tab) (keycode 83 = KP_Left KP_4 KP_Left KP_4) (keycode 113 = Left NoSymbol Left). I'm not sure whether this is good or bad... Sometimes, the behaviour is as expected, sometimes not. I still haven't found the trigger. – brice Aug 16 '11 at 11:30

Click on the application icon on the Unity bar. Type keyboard and double click on the entry labelled as, "Keyboard Shortcuts. Scroll down the list until you get to the item that says, "Move window one workspace to the left". Click on each of items and change the shortcut to your liking.

share|improve this answer
It's not an unity issue, proably more low-level. – Jocelyn delalande May 31 '15 at 15:04

Finally found how to work around that, for the records, that behaviour means that the underlying tty is still capturing events (in ttys, meta/alt + left/right is bound to console switching).

In my /etc/X11/xorg.conf,

I had :

Section "InputDevice"
     Identifier "Keyboard0"
     Driver "evdev"
     Option "Device" "/dev/input/event1"
     Option "XkbRules"  "xorg"
     Option "XkbModel"  "pc105"
     Option "XkbLayout" "fr,fr"
     Option "XkbVariant" "oss,bepo"
     Option "XkbOptions"    "grp:shift_toggle,grp_led:scroll"

I added the following line : Option "GrabDevice" "True" in the above section, restarted X and voila :)

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.