Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just spent a day trying to work around my newly upgraded Ubuntu 14.04 booting into a black screen without success and becoming seriously desperate.

What I did: Upgrade to 14.04 LTS from 13.10 via command line. Everything proceeded without problems.

The status now: GRUB shows. After I select any Ubuntu starting option I still have on my system, the Ubuntu start screen with the dots appears, changes into a black screen with a white cursor in the upper front corner. At this stage nothing will get me out of this besides a manual restart (Alt + F1 or F2 does not work, no keyboard reactions otherwise). This effect also happens with the Ubuntu 13.10 kernel stilled imaged on the system. Graphics failsafe modes won't boot at all. I can get to a text mode boot via selecting recovery mode and from there return to normal boot --> login to 14.04 works, but no display is recognized.

My System:

Thinkpad X1, dualboot with Windows 7. Intel HD 4000 graphics card. There is no file /etc/X11/xorg/conf.

lspci -nnk | grep -iA3 vga Yields:

00:02.0 VGA compatible controller [0300]: Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] (rev 09)

Subsystem:

Lenovo Device [17aa:21f9] Kernel driver in use: i915 00:14.0 USB controller [0c03]: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller[8086:1e31] (rev 04)

/usr/lib/nux/unity_support_test -p yields:

No protocol specified
  Error: unable to open display

What I tried: Many suggested solutions from other forum threads, including Resetting unity, dpkg --reconfigure, several installations and re-installation of fglrx / nouveau / nvidia graphics drivers, reinstalling X, .......

Booting 14.04 from a live USB, which works great and enables me to write this post, but I don't manage to fix my local 14.04 installation

share|improve this question
1  
    
generally speaking, when you have a problem with an upgrade, it takes longer to debug it then to do a fresh install. A fresh install will preserver your data in /home. My general policy, if I can not fix an upgrade within 20 min, fresh install. Support for failed upgrades is limited. With that in mind, check your logs for errors. –  bodhi.zazen Jun 5 at 19:53
    
Hi, @bodhi.zazen: Thanks for the link to the former thread. I already went through it, tried the suggested solutions with no success. How can I proceed to a fresh install without loosing my data? E.g. sudo apt-get dist-upgrade shows me everything is already perfectly up to-date .. –  Alice Jun 5 at 20:02
    
Your data in /home is preserved "Since Hardy it is possible to reinstall Ubuntu without losing the content of the /home folder (the folder that contains program settings, internet bookmarks, emails and all your documents, music, videos and other user files). This can be done even if /home is not on a separate partition" see help.ubuntu.com/community/UbuntuReinstallation . If you have data outside of /home it of course gets more interesting, but you have several back up strategies. –  bodhi.zazen Jun 5 at 20:06
    
I have a physical update of all my data on an external drive generated with ubuntu simple backup. I just went to the first screen of a reinstall of 14.04. from a life USB I generated today and my options were installing it alongside the broken 14.04 on my system or loosing all data. From my broken 14.04 I cant run ubuntu installer since i cant boot.. –  Alice Jun 5 at 20:09

1 Answer 1

up vote 0 down vote accepted

As suggested by bodhi.zazen, a reinstall of 14.04. from a life USB following this link enabled me to boot into 14.04. without loosing my /home/ data.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.