Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

While using plymouth, I have late splash and tried to fix it, I googled and got lots of suggestions on doing this:

vi /etc/initramfs-tools/conf.d/splash 

and add:

FRAMEBUFFER=y

and

update-initramfs -u 

After doing this, I have no splash at all. So I deleted the FRAMEBUFFER=y and re-update initramfs, splash came back.

After that I installed something, maybe it's remastersys or n86v or their dependencies, or something else, I have splash gone again and according to the boot.log, I think it's due to framebuffer enabled in initramfs again.

I tried FRAMBUFFER=n in /etc/initramfs-tools/conf.d/splash but failed.

Now I have no splash and still can't get it back.

Does anyone know how to disable framebuffer in initramfs?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

I solve it on my own.

I find that when splash doesn't show, I see there's a text on the screen:

"plymouthd could not start boot splash too many levels of symbolic links"

I unzip initrd and look into it, I check lib/plymouth/themes,

the default.plymouth is a s link which links it self!!!

I edited it and zip the initrd, reboot, works fine.

Even though there's still something wrong in fb and initramfs, splash came back, I got what I wanted.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.