Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a HP desktop machine with Ubuntu 14.04, with also Xubuntu and Gnome desktops installed. I mostly use the Xubuntu session.

When using the Xubuntu session, when I power off my monitor, and power it back on, the screen stays black and I cannot do any work. With ctrl-alt-f6 I can open another virtual terminal, and then the screen works again, but if I to go back to the desktop session with ctrl-alt-f7, all I have is a black screen.

But, if I login to Unity (the Ubuntu default session), or to Gnome, and turn the monitor off and back on, everything works ok. Also, if I log out, and while in the lightdm greeter, turn the monitor off and back on, everything works ok.

What could be the cause for this, and how to fix this?

share|improve this question
1  
I cannot reproduce this issue, but I wonder if this is related to a similar bug when going into standby ? There is a fix at bugs.launchpad.net/ubuntu/+source/xfce4-power-manager/+bug/… if that does not work, I suggest filing a new bug report. –  NGRhodes Jun 5 at 9:46

4 Answers 4

I had this same problem with a brand new installation on my old Thinkpad T43. I made some changes in the settings that not only fixed it for me, but made it better than ever.

By better than ever... when I close the lid now, the computer goes into full suspend mode (not just blanking the screen). When I open the lid, it immediately comes back, with no login prompt, ready to use. This may not be what you want, but it might be what fixed the blank screen problem - I really haven't investigated because I kind of like it this way.

Now, unfortunately, I made a few changes at once, so I'm not sure exactly which one is important, so I'll list some settings that I have made.

Power Manager Settings

  • General - checkbox for "Monitor power management control" is checked.
  • On AC (and on Battery) - When lid is closed, Suspend. Put computer to sleep... Never

Light Locker Settings

  • Locking - "Enable Light Locker", Off
  • Lock on Suspend, Off (but disabled, so probably doesn't matter)

In case I missed something, if you have any questions, feel free to ask

share|improve this answer

I have the same issue (Xubuntu 14.04, my laptop is a Acer Aspire 5930G) with all the latest updates applied.

One solution that worked for me is to disable the light locker. However this makes it impossible to lock the laptop. It made no difference what I put into the Power Manager (Suspend or Do Nothing).

Not that great when I am in the office but I haven't found any other solution. So I have kept the light locker on but never close the lid when the computer is on :-(

share|improve this answer

I had this problem after upgrading to 14.04. I have an nvidia graphics card and a Vizio TV connected by HDMI.

To get back to an X session: Ctrl-Alt-F1

login

sudo service lightdm restart

Reset the audio either in alsamixer or I just go to setup/audio in MythTV. Just entering the audio menu resets it.

To permanently fix the problem, I found the solution here:

http://www.gossamer-threads.com/lists/mythtv/users/570769

if you don't have an xorg.conf file in /etc/X11 then use nvidia-xconfig to create one. Then, in the "Device" section, add:

Option "UseHotplugEvents" "false"

restart lightdm to make it take affect.

That should be enough. Though I also added Option "Hotplug" "false" and under "Monitor" I added Option "DPMS" "false" to avoid any other power control of the monitor.

share|improve this answer

These steps work for me:

  1. Go to "Power Manager"
  2. Click tab "On AC"
  3. Select the tab "Monitor".
  4. Set "Switch off display when computer is inactive" to never.

This way, the screens are never turned off, and the problem no longer occurs.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.