Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm on Ubuntu 14.04 and when i booted it the sound was working. But it wasn't working the way it does on Windows 7, like in it there is a feature for me to use Dolby Technology to create really nice sound. On Ubuntu, it just really bad just 'treble?" and no bass. It doesn't even use the subwoofer present on my laptop.

So I tried installing this [extracted, complied, install make]. Used the Linux version. It just completely broke the sound system on my laptop. NO more sound or anything.

I did this too from a thread I found,

sudo apt-get --purge remove linux-sound-base alsa-base alsa-utils
sudo apt-get install linux-sound-base alsa-base alsa-utils

It didn't to anything. Now I ran this command

 wget -O alsa-info.sh http://www.alsa-project.org/alsa-info.sh && bash alsa-info.sh --upload

and this is its output.

My laptop is Qomsio F 50-126 with builtin Subwooder and two speakers and running Ubuntu 14.04.

The image of the Sound Setting Window

share|improve this question

1 Answer 1

up vote 0 down vote accepted

The Dolby thing is done by software emulation in the Windows driver. No Linux driver will have it.

The sound drivers are part of the kernel. Reinstall (or update to a newer version, if possible) the kernel package (linux).

share|improve this answer
    
Dolby thing is definitely not emulation because it actually activates one of the laptop hardware component. Kernel version I have right now is 3.13.0-24-generic. I'm pretty sure its not not the kernel problem but instead me removing one of the audio driver setting. –  user280930 Jun 5 at 8:59
    
What hardware component? And the Realtek installer did change the kernel modules. –  CL. Jun 5 at 9:03
    
Ok, I'm going to run system update and hopefully it reinstall the sound driver and fixes it. The hardware is a subwoofer under the laptop. The computer is actually 2.1 Stereo system. Its definitely not emulation like emulate sounds as if in a auditorium, home theater, zoo etc –  user280930 Jun 5 at 9:40
    
Updating fixed it but I still miss my sub woofer functionality. –  user280930 Jun 6 at 17:56
    
This is me, I just gave up. –  user280930 Sep 19 at 17:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.