Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've been using Linux for quite a while in everyday computing and programming. But now i got this new laptop with amazing battery life on windows which runs pretty cool even while gaming. But for some reason on Ubuntu I get like 1/3 battery life and it gets hot even while browsing the web.

I have the proprietary drivers for radeon, but I'm thinking about upgrading from Ubuntu 12.04 to 14.04, and I would like to know how can I use only the Intel graphics and have radeon always turned off? Since I do not need the discrete graphics on Ubuntu and I'm pretty sure my problem is related to the radeon sucking up my battery and generating heat.

My laptop technical specifications are:

  • Dell latitude 3540
  • Intel core i7 4500U (with Intel hd4400 graphics )
  • Ati Radeon HD 8850m with 2GB GDDR5 VRAM
  • 8 GB DDR3L @1600mhz
  • Toshiba 256gb SSD
  • Ubuntu 12.4.3

If you need any additional info, please tell me :)

share|improve this question
Check you BIOS. Sometimes it lets you turn one or the other off. – Seth Jun 5 '14 at 2:47
@luizrogeriocn This could be a very useful read for you: – VenkiPhy6 Jun 5 '14 at 3:35
up vote 1 down vote accepted

Install Catalyst Control Center:

enter image description here

Open your Terminal and execute:

sudo apt-get install fglrx

Then reboot.

share|improve this answer
Great! I had tried this in the past using another laptop on ubuntu 13.04 and if i chose the Intel option it would end up with a black screen upon reboot. But now on ubuntu 14.04 and with this new laptop it worked like a charm. Battery life went from ~3hrs to ~7hrs, and my temps are at least 15 to 20 degrees celsius cooler. Now I can finally use ubuntu for everyday computing and let windows only for gaming. Thanks a lot, dude :D – luizrogeriocn Jun 10 '14 at 6:13
Glad help you +luirogejdebje! :) – Naveen Jun 13 '14 at 13:15

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.