Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have just switched from OSX to Xubuntu 14.04 on my iMac Late 2013. I've got everything running smooth, except for my freakin' audio card. It works occasionally for a few minutes and then it just stops. I can't hear anything, but the sound indicator in the sound settings is moving.

I followed every single possible solution on askubuntu and the unbuntu forums but I couldn't get it to work permanently. The only thing that kinda works for me is force reloading the pulse audio driver. But I gotta do that a couple of times, including logins and log outs to reactive the sound for a few minutes.

I really don't want to give up, and hope you guys can help me figure this one out. I don't want to go back to OSX, I really like my new found freedom!

Let me know if you need more information, any help would be greatly appreciated!

**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: CS4206 Analog [CS4206 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 1: CS4206 Digital [CS4206 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Card: HDA Intel PCH                                 
Chip: Cirrus Logic CS4206
share|improve this question

2 Answers 2

up vote 2 down vote accepted

I had many issues with my late 2013 iMac 21.5" as well. The setup which currently works for me is the following:

  • Pulseaudio and alsa default settings
  • in /etc/modprobe.d/alsa-base.conf, make sure you have the following option

    options snd-hda-intel model=imac27_122

Then, speakers should work out of the box. To fix headphones, I had to use hda_analyzer.py, instructions are here. I actually had to modify the source a bit to run on my machine, let me know if you need further help with that.

Using hda_analyzer, make sure that you configure card-1 codec-0 as following: enter image description here

Sound should then work with both speakers and headphones. The [2] IO is your headphone, the [3] is the speaker. To make the changes permanent, use exp to save the changes to a script and call it in the boot process (e.g. in rc.local).

share|improve this answer
    
Thanks for the advice, it's much appreciated! By the way, do you also experience poor sound quality, like an old mono radio with a hissing noise on voices, especially when I turn the volume up? –  LinuxDudester Aug 14 at 17:29
    
What is the exp program you referred to? –  mqsoh Dec 2 at 16:31
1  
sorry, my markup is confusing, Exp refers to the button in the screenshot –  noleti Dec 5 at 23:23
  • You can try uninstalling Pulseaudio and test with the Alsa audio layer only:
    sudo apt-get purge pulseaudio
    sudo apt-get install gnome-alsamixer

  • Reboot and set the volume with the Gnome Alsa mixer (in the multimedia menu), or alsamixer in a terminal: it could be better as Pulseaudio is cpu consuming and not necessary for audio to work.

  • If you want to go back to Pulseaudio, look here :
    Audio suddenly stopped, pulseaudio reinstall has not helped? (14.04)[SOLVED]
share|improve this answer
    
Holy crap, thanks laugeo! This seems to have fixed my problem for now. Thank you Thank You Thank you, I am so super happy! Oddly enough I tried the Alsa Audio Layer before but it didn't work. Now it does and I'm so thrilled, my computer may look like a Mac, but it actually runs Linux exclusively! I can't thank you enough, you made my day! –  LinuxDudester Jun 5 at 0:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.