Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm having to set up an email server for a class and have installed exim (using Maildir mailbox format) and sent myself an email. I can't read the email though: I have set the MAIL variable to ~/Maildir but when I try to open mail I get

pad-20@PAD-20:~$ mail
mail: /home/pad-20/Maildir/: Is a directory

I also changed the settings in /etc/pam.d/{login,su,sshd} according to this guide, but all that's done is give me a new email summary when I log in.

The strange thing is that frm works:

pad-20@PAD-20:~$ frm
    Test 2 from telnet

(That's the subject of the test email I sent).

There is another question on askubuntu that is similar, except that their problem was fixed after setting the MAIL variable correctly.

share|improve this question

1 Answer 1

up vote 9 down vote accepted

The traditional unix /usr/bin/mail only supports mailbox format. It's older than maildir, after all.

Under Ubuntu, /usr/bin/mail has two alternatives: heirloom-mailx Install heirloom-mailx and bsd-mailx Install bsd-mailx. Each of the two have extensions to the historical utility, but the Heirloom version more so. In particular, Only the Heirloom version has maildir support (and IMAP, and decent charset handling, and MIME).

Make sure you have the Heirloom version installed. If you have both, the alternative defaults to heirloom-mailx; check that you haven't changed the default setting by running sudo update-alternatives --config mailx.

share|improve this answer
    
Thanks, installing heirloom-mailx solved the issue. I'd vote you up too but don't have enough rep. –  bob esponja Jun 9 '11 at 10:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.