Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Background: Running kubuntu 14.04, using kdm. I have a Brother MFC7280N, and installed the brscan2 package. Nevertheless I have never been able to scan, since the device is never found. I removed (I thought) brscan2 in hopes of reinstalling.

I had installed Kompozer, and had to remove it when it started to display funky video. I have tried to reinstall it but without success. I haven't edited any config files, except to add a repository for Kompozer (failed), or done anything other than run apt-get and the software center. That is, I haven't tried any strange (to me) commands to install, remove, or modify the installed software. I did try to install Kompozer from a .deb file and also from two tarballs.

Now I can't install or remove any software using apt-get or the Ubuntu Software Center. Here's an example: << root@LEX:/home/bill# apt-get remove brscan2 Reading package lists... Done Building dependency tree
Reading state information... Done You might want to run 'apt-get -f install' to correct these: The following packages have unmet dependencies: kompozer:i386 : Depends: libatk1.0-0:i386 (>= 1.9.0) but it is not going to be installed Depends: libcairo2:i386 (>= 1.0.2-2) but it is not going to be installed Depends: libgtk2.0-0:i386 (>= 2.8.0) but it is not going to be installed Depends: libidl0:i386 but it is not going to be installed Depends: libpango1.0-0:i386 (>= 1.12.3) but it is not going to be installed Depends: libxft2:i386 (> 2.1.1) but it is not going to be installed E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

>

This is so strange that I don't have any notion of what to make of it. So I need some expert guidance. Many thanks!

share|improve this question

2 Answers 2

It seems that you installed a deb file that requires libraries that are incompatible with Ubuntu 14.04's libraries. You should simply uninstall what you installed.

sudo apt-get purge kompozer:i386

share|improve this answer
    
It complained that it couldn't remove a bunch of directories hainvg to do with Brother (and how do I get a newline here?). Errors were encountered while processing: brscan2 E: Sub-process /usr/bin/dpkg returned an error code (1) –  lunix Jun 4 at 15:35
    
It's as though no matter what I am trying to install or remove, apt-get thinks I typed brscan2. –  lunix Jun 4 at 15:40
    
It's still broken. Can anyone help? –  lunix Jun 10 at 21:34

I just had this happen.

I believe the problem is twofold: 1) Brother's .deb linux packages are (were never) packaged well, and 2) the binaries are not compatible with Ubuntu 14.04.

Here's the whole scenario with the package that won't go away:

user@sys:~$ sudo apt-get purge brscan2
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  brscan2:i386
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] 
(Reading database ... 214320 files and directories currently installed.)
Removing brscan2 (0.2.5-1) ...
rmdir: failed to remove ‘/usr/local/Brother/sane/GrayCmData/ALL’: No such file or directory
rmdir: failed to remove ‘/usr/local/Brother/sane/GrayCmData/AL’: No such file or directory
rmdir: failed to remove ‘/usr/local/Brother/sane/GrayCmData’: No such file or directory
rmdir: failed to remove ‘/usr/local/Brother/sane/models2’: No such file or directory
rmdir: failed to remove ‘/usr/local/Brother/sane’: No such file or directory
rmdir: failed to remove ‘/usr/local/Brother’: No such file or directory
dpkg: error processing package brscan2 (--remove):
 subprocess installed post-removal script returned error exit status 1
Errors were encountered while processing:
 brscan2
E: Sub-process /usr/bin/dpkg returned an error code (1)
user@sys:~$

You see, the package failed to be completely removed because the code it needed to execute to remove the package hung up on some missing directories.

Here's a workaround that worked for me: I created the missing directories, and purged the package successfully.

user@sys:~$ sudo mkdir -p /usr/local/Brother/sane/GrayCmData/
user@sys:~$ sudo mkdir -p /usr/local/Brother/sane/GrayCmData/ALL
user@sys:~$ sudo mkdir -p /usr/local/Brother/sane/GrayCmData/AL
user@sys:~$ sudo mkdir -p /usr/local/Brother/sane/models2

After I created the directories...

user@sys:~$ sudo apt-get purge brscan2
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  brscan2:i386
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] 
(Reading database ... 214320 files and directories currently installed.)
Removing brscan2 (0.2.5-1) ...
user@sys:~$

The software purge succeeded. Needless to say I am going to be using a different scanner now.

I hope this trick helps someone!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.