Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

Recently, I finally got the official drivers for my NVIDIA 560 Ti card installed on Ubuntu 14.04 (hooray) However I started looking into installing Steam and I'm getting segmentation errors when I try to run the software. I tried installing 32-bit libs and it seemed like they weren't available or they were already installed. Upon further investigation, I found that a solution is to install the proprietary drivers, install steam then switch back to the other drivers. I'm not really sure what "proprietary drivers" are in all honesty. Has anyone gone through this process that could provide some insight here?

(I installed the official 64-bit driver from the NVIDIA site for my 560 Ti just for reference. And the Ubuntu version installed is 64-bit as well)

Update:

This is the error text I get when trying to run steam after installing it via the ubuntu store.

Running Steam on ubuntu 14.04 64-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(1401381906_client)
/home/dbrewer/.steam/steam.sh: line 755:  3943 Segmentation fault      (core dumped) $STEAM_DEBUGGER "$STEAMROOT/$PLATFORM/$STEAMEXE" "$@"
mv: cannot stat ‘/home/dbrewer/.steam/registry.vdf’: No such file or directory
Installing bootstrap /home/dbrewer/.steam/bootstrap.tar.xz
Reset complete!
Restarting Steam by request...
Running Steam on ubuntu 14.04 64-bit
STEAM_RUNTIME has been set by the user to: /home/dbrewer/.steam/ubuntu12_32/steam-runtime
Installing breakpad exception handler for appid(steam)/version(1401381906_client)
/home/dbrewer/.steam/steam.sh: line 755:  4066 Segmentation fault      (core dumped) $STEAM_DEBUGGER "$STEAMROOT/$PLATFORM/$STEAMEXE" "$@"

What I get when I run "steam --reset"

mv: cannot stat ‘/home/dbrewer/.steam/registry.vdf’: No such file or directory
Installing bootstrap /home/dbrewer/.steam/bootstrap.tar.xz
Reset complete!
share|improve this question

marked as duplicate by Eric Carvalho, Jorge Castro, waltinator, Eliah Kagan, mikewhatever Jun 27 at 8:20

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
The official 64-bit driver from the NVIDIA homepage is a proprietary driver. Proprietary means in this case that only NVIDIA developers have access to its code, so no one but NVIDIA knows exactly what the code looks like and if there are any errors or backdoors or something. As only NVIDIA exactly knows how to talk to their graphic cards they can make drivers with higher performance than others who have to try what commands the graphic card understands and what they do. –  Kai Jun 4 at 14:19
    
Did you install steam through the Ubuntu Software Center? I did it and everything worked out of the box (NVIDIA card, 64bit). –  Kai Jun 4 at 14:20
    
I did. I searched for "Steam" through the software center and found "steam-launcher" I installed that and it wasn't loading it seemed. I found another "steam" but it said it couldn't find the package. Mind you this is out of the box and I'm wondering if maybe I missed adding a repo or something. –  allthosemiles Jun 4 at 14:29
    
I also get the same error when I click on the "steam" package (I used 'steam-launcher', too). What do you mean by 'not loading'? Couldn't the application be downloaded or isn't it possible to launch it? –  Kai Jun 4 at 14:35
    
I just purged it from the system and installed it from that steam-launcher again in the store and when I click the icon it just blinks a few times then stops. (see update in question for error text) –  allthosemiles Jun 4 at 20:48

1 Answer 1

up vote 0 down vote accepted

Found a solution. (Maybe not the best one)

My original steps were to install Ubuntu, install the drivers (via the official download from the site) then install steam. That didn't work and I could never get it working.

My solution to this, was to install Ubuntu fresh again, install steam first, then install the drivers. I set Ubuntu to use the proprietary drivers through additional drivers. So far so good! Everything is loading like it should.

Re-cap steps:

  1. Install Ubuntu fresh (i'm using 14.04)
  2. Install Steam (I did this via the Software Center in Ubuntu)
  3. Use the proprietary drivers for your graphics card (I selected mine through the additional drivers tab, which is under Software and Updates)
share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.