Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This question already has an answer here:

Since upgrading from 12.04 to 14.04, whenever I connect my Android Galaxy SII to my laptop via USB to charge, I get a dialog box that says

  Unable to mount SAMSUNG Android
  Unable to open MTP device '[usb:002,021]'

If I want to mount it, I select the mounting option on the phone as usual, and it mounts fine as a USB mass storage device. I don't know why Ubuntu is trying to mount the device before it switches to USB mass storage mode.

Is there a way to disable this automounting, or at least to disable the dialog boxes when it fails? (I still want other USB devices to be mounted when inserted, as usual.) In other words, I want the sane 12.04 behaviour back.

share|improve this question

marked as duplicate by Pilot6, Community Oct 9 '15 at 12:55

This question was marked as an exact duplicate of an existing question.

    
You can answer yourself now? I suffer from the same problem, also S2. – Robert Siemer Jun 18 '14 at 17:14
    
No, I haven't been able to solve this yet. I happens every time I plug my phone in to charge, which is annoying... – Dan Christensen Jun 18 '14 at 20:54
  1. Install dconf-editor.
  2. Go to org -> gnome -> desktop -> media-handling
  3. Uncheck automount_open
share|improve this answer
1  
This doesn't answer the question, since I still want other devices to mount automatically. I just don't want to see the MTP error dialogs. – Dan Christensen Oct 9 '15 at 12:55

Not the answer you're looking for? Browse other questions tagged or ask your own question.