Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This morning I found that I cannot change the brightness of my Dell XPs 13 laptop's display anymore. I tried the following to change the brightness

  • Use keyboard brightness keys
  • Run the commands shown below
  • Boot with kernel option acpi_backlight=vendor. This resulted in a dell_something folder being present in the /sys/class/backlight folder. Changing the brightness file in that folder does not help.
  • Add 'intel_backlight' to xorg.conf
  • Set "load legacy option ROM" BIOS option to enabled and "secure boot" to disabled
  • Boot with kernel option i915.disable-pch_pwm=0
  • Boot from a fresh Ubuntu 12.04 USB stick installation. I can still not control the brightness. This is strange as the laptop came preinstalled with 12.04. Maybe this a hardware problem?
  • Install latest intel video driver

Any ideas why this broke suddendly? I've upgraded from 12.04 to 14.04 in April and till yesterday the brightness keys were working fine.

Thanks!

echo 100 > /sys/class/backlight/intel_backlight/brightness
echo 100 > /sys/class/backlight/acpi_video0/brightness
share|improve this question
    
I used some help from this blog: itsfoss.com/fix-brightness-ubuntu-1310 It worked on a dell. Not able to run it on an acer.Hope it works for you –  user3058470 Jun 4 '14 at 10:58
    
Thanks for your help. I found that article myself but I figured that solve the problem. The changes in the xorg.conf just make the brightness buttons work by echoing the appropriate value in thebrightness file. My problem, however, is that even when I manually changethe value the brightness does not changed. –  Lespaul86 Jun 4 '14 at 13:09

6 Answers 6

I got a fix for my dell 5521 laptop,

working for ubuntu 14.04 but will work for kernels v3.13+

sudo nano /etc/default/grub

change line

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" to 

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash video.use_native_backlight=1"

then save and exit and run

sudo update-grub

then reboot

explanation is that acpi adds its own backlight control even if one is already present which is intel_backlight, adding this line forces acpi to use the intel backlight.

share|improve this answer
2  
I can conform, that this fix my problem in up-to-date Ubuntu 14.04.1 TLS version. –  Jupeter Feb 6 at 19:21

For me, solution listed here helps - https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1249219/comments/30

Basically it works creating the /usr/share/X11/xorg.conf.d/20-intel.conf file with the following lines:

Section "Device"
        Identifier "card0"
        Driver "intel"
        Option "Backlight" "intel_backlight"
        BusID "PCI:0:2:0"
EndSection
share|improve this answer

I used this solution, it's very simple and easy:

  • Install xbacklight
  • Open Startup Applications
  • Add a new startup item, (give it a name and in the command line type: xbacklight -set 50)

50 gave me the level of brightness I needed but you may need to experiment with the values for your particular system.

share|improve this answer
    
I find it easier to just use xbacklight -set 50 in the terminal. –  I Like to Code May 29 at 3:43

This worked for my eeepc seashell series: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux" from http://ubuntuforums.org/showthread.php?t=1412922 and they got it from http://wiki.debian.org/DebianEeePC/Model/1005pe

share|improve this answer
    
While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. –  KasiyA Nov 19 '14 at 4:41
  • Open Terminal, run sudo gedit /etc/rc.local
  • It will ask for password. Type your password.
  • Then, the text editor will pop up with rc.local file opened. It contains some stuff and in the end exit 0.
  • Before that exit 0 line, add below commands to reduce brightness in Ubuntu:

    sudo sh -c "echo x > /sys/class/backlight/intel_backlight/brightness"
    sudo sh -c "echo y > /sys/class/backlight/acpi_video0/brightness" # (optional)
    sudo sh -c "echo y > /sys/class/backlight/acpi_video1/brightness" # (optional)
    

    where 0 <= x <= 4882 and 0 <= y <= 10.

  • That's it. Save and restart your machine.
share|improve this answer
    
ya. Its works for me. Thanks –  Phoenix Apr 18 at 20:36

I have read A LOT of articles

Here is what I did, as I've been struggling with this for a long time...

Creating and modifying /usr/share/X11/xorg.conf.d/20-intel.conf file with the following lines...

Section "Device"
   Identifier "card0"
   Driver "intel"
   Option "Backlight" "intel_backlight"
   BusID "PCI:0:2:0"
EndSection

...didn't work at all

I was using xbacklight option for some time, but it didn't satisfy me, as I knew it must be possible with Linux native way.

I've tried many GRUB options without effect, so I was googling again and again, coming back to solve this issue.

Today I came to the solution, which is following:

  1. You need to kill your display manager, to create new Xorg.conf file (because it runs X server):
    • Press Ctrl+Alt+F1 (Dont panic, while your Window system is runing, you can go back with Ctrl+Alt+F7)
    • typesudo service lightdm stop and press Enter(e.g. gdm, kdm, xdm)
  2. Create new Xorg configuration file
    • type X -configure and press Enter
    • type mv xorg.conf.new /etc/X11/xorg.conf and press Enter
  3. Start X Server (you can do it all without GUI via command line, but I was more comfortable with this aproach):
    • typesudo service lightdm start and press Enter(e.g. gdm, kdm, xdm)
  4. Modify Xorg.conf file
    • navigate to /etc/X11/xorg.conf and open Xorg.conf (in my case latest was xorg.conf.05312015) via leafpad (e.g. gedit, pluma)
    • search for Section "Device" and then for Driver (on my PC it said Driver "intel" by default, but it could be something else, so change it to intel)
    • add line Option "Backlight" "intel_backlight" after Driver "intel" (it doesn't really matter where, as long as it stays in Device Section)
    • save
  5. Modify GRUB

    • sudo gedit /etc/default/grub (e.g. leafpad, pluma...)
    • set to GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=" (acpi_osi= did it for me, other options didn't work...)
    • in terminal type sudo update-grub and press Enter
    • or use GRUB customizer:

    sudo add-apt-repository ppa:danielrichter2007/grub-customizer sudo apt-get update sudo apt-get install grub-customizer

Grub customizer

  • press Save in upper left corner, which will update GRUB for you

    1. Restart and profit

Funny thing is, that code is exactly the same as in /usr/share/X11/xorg.conf.d/20-intel.conf, but that way it worked as expected!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.