Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When the PC starts my M-Audio Delta 66 is using 48000kHz sampling rate when it is set for 44100 in Envy24. This causes audio to play slower than it should.

This is in Kubuntu 14.04 on my new PC using an AMD A8 6500 with 8GB. When I first installed it seemed okay, but at some point it went wrong and has been doing this consistently since then.

Kernel is 3.13.0-24-generic #47-Ubuntu SMP Fri May 2 23:31:42 UTC 2014 i686 athlon i686 GNU/Linux

steve@slarti:~$ cat /proc/asound/card2/pcm0p/sub0/hw_params access: MMAP_INTERLEAVED format: S32_LE subformat: STD channels: 10 rate: 48000 (48000/1) period_size: 441 buffer_size: 3528

I can get it to switch to 44100 if I disable/enable the Delta in Pulseaudio volume control, but I have to do this every day and the sound still seems distorted. I can't see any issues in any of the config or log files I can find.

If I boot the PC with a Mint Live USB it starts at 44100 and sound fine.

Originally reported on Youtube is playing at the wrong speed - maybe soundcard related, but I'll close that and have this more relevant question instead.

share|improve this question

1 Answer 1

There have been some updates since then and it seems to be okay now.

Current kernel 3.13.0-29-generic #53-Ubuntu SMP Wed Jun 4 21:02:19 UTC 2014 i686 athlon i686 GNU/Linux

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.