Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running Ubuntu 13.10 using an AMD/ATI graphics card Gallium 0.4 on AMD RS880.

Since the last kernel update Unity no longer works. When I log in I only get the desktop wallpaper - no unity panel or top panel. Also, if I start an application it will have no frame.

I have tried numerous fixes.

I am using the open source AMD/ATI driver wrapper from xserver-xorg-video-ati. I cannot use fglrx at all (I have tried on numerous occasions but my laptop will only boot into the low-res graphics version).

I have checked ccsm and the unity plugin is checked.

I have come across numerous fixes on the web but none have worked. These including reinstalling unity, ubuntu-desktop, compiz, as well as reseting them all.

I am currently logged in using Gnome, which works fine, but I would like to have Unity back. It only stopped working on the last update. I have tried booting to the previous kernel but that does not work.

Any help warmly appreciated.

share|improve this question
    
You could try updating to 14.04, it has a slightly newer version of xserver-xorg-video-ati that, at this point, is probably getting more testing than 13.10. You could also try updating the kernel to a newer one from the mainline kernel PPA. And report the bug to Xorg radeon upstream at wiki.x.org/wiki/radeon - they have bug tracker, IRC and mailing list. Your GPU is HD 4000 series so it will not work with the proprietary drivers. –  bain Jun 4 at 0:09
    
As a quick check, you could try booting the 14.04 iso and "Try Ubuntu". It is possible your problem has already been fixed in 14.04. –  bain Jun 4 at 0:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.