Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Often the audio quality is very bad so I've to restart the audio backend.

When I'm using ALSA I can't since the command to restart it seems not to find the file (strange as ALSA works..) when I'm use pulseaudio, I can restart with pulseaudio -k in a terminal.

OSS never worked to me. When Ubuntu used ESD, the audio always worked (Ubuntu 10.04 or maybe earlier).

Someone encountered similiar problem? Which backend do you use?

I've an integrated nvidia soundboard (MCP77/78 HDMI).

share|improve this question
    
Please specify what it is that is 'bad' on your system –  Takkat Jun 8 '11 at 11:11

2 Answers 2

Ubuntu has been using a very similar stack to the current one (PulseAudio on ALSA) by default since 8.04. If 10.04 worked for you, I'd take off the rose-tinted glasses because they're lying to you. Each sound system has its pros and cons. PulseAudio is just the best of a imperfect mix for most people.

The command to restart ALSA (on 11.04) is:

sudo /etc/init.d/alsasound restart

You might need to install the alsa-utils package. That just does a load of things with alsactl.

As for poor sound quality, I find that sometimes funny balance/fade settings can cause major distortion. A tool like padevchooser's mixer might help you straighten things out.

share|improve this answer
    
Now I'm on Pulseaudio (it uses ALSA?). I've already installed alsa-utils e alsactl... Now I'll try something with padevchooser and with pulse .conf file listed below (backupping the old one). –  Hadden Jun 10 '11 at 15:32
    
sudo /etc/init.d/alsasound restart doesn't work... It says "command not found". However I'm trying to do some tricks with padevchooser (as recommended) and it seems to be a possible solution... We'll see :) –  Hadden Jun 13 '11 at 13:35

To configure audio settings that affect sound quality we have a configuration file /etc/pulse/daemon.conf where we can fine tune a lot of settings, depending on your indivdual system or problem. This file can be edited as root with any editor.

For my system the following settings turned out to be fine (leaving all other parameters commented out):

resample-method = speex-float-1
default-fragments = 8
default-fragment-size-msec = 10

Always make a backup of this file before editing in case you made changes that break your audio.

share|improve this answer
    
It seems to happen random. I open an application, then another and after a while the audio is very disturbed... I'll try both the setting for alsa and pulseaudio :) –  Hadden Jun 10 '11 at 13:53
    
It often happens with nautilus or firefox opened (so when the CPU/ram is well stressed). –  Hadden Jun 10 '11 at 17:16
    
We still don't know what "it" is that is "disturbed". Try uncommenting high-priority = yes - this may slow down other applications. –  Takkat Jun 10 '11 at 18:56
    
It seems to be resolved with padevchooser and some ubuntu updates :) –  Hadden Jun 26 '11 at 16:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.