Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I tried to update Grub so I run:

sudo update-grub

Generating grub configuration file ...
Warning: Setting GRUB_TIMEOUT to a non-zero value when GRUB_HIDDEN_TIMEOUT is set is no longer supported.

What exactly this warning wants to be changed? (I upgraded from 12.04 to 14.04 before)

This is my /etc/default/grub file:

GRUB_DEFAULT="0"
GRUB_HIDDEN_TIMEOUT="0"
GRUB_HIDDEN_TIMEOUT_QUIET="true"
GRUB_TIMEOUT="10"
GRUB_DISTRIBUTOR="`lsb_release -i -s 2> /dev/null || echo Debian`"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""
share|improve this question
up vote 17 down vote accepted

You can't use the GRUB_HIDDEN_TIMEOUT setting and the GRUB_TIMEOUT setting at the same time. This is true even when the hidden timeout is set to 0.

You can comment out the line that you don't want.

For example:

#GRUB_HIDDEN_TIMEOUT=0

After saving the change, run sudo update-grub again.

share|improve this answer
    
Thank you. Seems ok now. – JoKeR Jun 3 '14 at 1:17
1  
Glad it worked out. :) – chaskes Jun 3 '14 at 1:20
    
one more question as my GRUB_HIDDEN_TIMEOUT was set to ="0" and GRUB_TIMEOUT to value ="10" will it reflect on anything? I mean should it be set to "10" or "0" – JoKeR Jun 3 '14 at 1:28
2  
It just depends on what you want. If you only have ubuntu, 0 is fine for timout. If you dual boot, you want some time (like 10) for choosing which os to boot. For more info see configuring grub2 – chaskes Jun 3 '14 at 1:36
    
Thanks again! I got it now, I use only Ubuntu. – JoKeR Jun 3 '14 at 1:37

Short answer:

#GRUB_HIDDEN_TIMEOUT=0
#GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT_STYLE=hidden

Or just delete the first two lines in the entry above and replace it with GRUB_TIMEOUT_STYLE=[menu|countdown|hidden]

Explanation:

As of this time (2016) the GRUB_HIDDEN_TIMEOUT and GRUB_HIDDEN_TIMEOUT_QUIET options have already been depreciated. So don't use them any more. Instead, you can use GRUB_TIMEOUT_STYLE.

According to info -f grub -n 'Simple configuration'

You have this:

'GRUB_TIMEOUT_STYLE'

 If this option is unset or set to 'menu', then GRUB will display
 the menu and then wait for the timeout set by 'GRUB_TIMEOUT' to
 expire before booting the default entry.  Pressing a key interrupts
 the timeout.

 If this option is set to 'countdown' or 'hidden', then, before
 displaying the menu, GRUB will wait for the timeout set by
 'GRUB_TIMEOUT' to expire.  If <ESC> is pressed during that time, it
 will display the menu and wait for input.  If a hotkey associated
 with a menu entry is pressed, it will boot the associated menu
 entry immediately.  If the timeout expires before either of these
 happens, it will boot the default entry.  In the 'countdown' case,
 it will show a one-line indication of the remaining time.
share|improve this answer

change

GRUB_TIMEOUT="10"

to

GRUB_TIMEOUT="0"

If you are not dual booting

and then

sudo update-grub
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.