Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I have downloaded the backend and front end of mythtv for 14.04 but when I open up the backend to configure I get a screen to select country then on the next page I get: MythTV could not connect to the database. Please verify your database settings below. Required fields are marked with and asterisk (*).

*Hostname: localhost [/]Ping test server? Port:3306 Database name: mythconverg User: mythtv Password: mythtv

All of that was already filled out, I haven't changed anything. The only answer I have found to this issue is for mythbuntu located here.

share|improve this question
    
Are you sure mysql is running? try running: "sudo status mysql" from a terminal –  Nick Veitch Jun 2 '14 at 20:59
    
I entered that and got: mysql start/running, process 1126 I tried going back into mythtv backend and it still did the same thing. –  xmjsilverx Jun 3 '14 at 0:37
    
Do you create a password during the mySQL install. I've notice a problem whenever I try anything other then a carriage return (CR) as the default password. –  user288686 Jun 5 '14 at 11:27
    
I am not sure what MySQL is but it shows its installed. I don't know how to edit the password. –  xmjsilverx Jun 5 '14 at 16:48

2 Answers 2

up vote 0 down vote accepted

The answer was to reinstall MySQL and enter "mythtv" as the password there as well. All other posts showed to leave the password blank in MySQL but that did not work. Here is the resource page I used to fix the problem.

share|improve this answer
    
More here: forum.mythtv.org/viewtopic.php?f=29&t=201 –  nobar Mar 20 at 6:16

I found the correct password (which was randomized) in /etc/mythtv/config.xml and entered this in the Password: field of the MythTV setup screen. This solved the problem for me. mythtv was not the correct password. This issue may be Ubuntu/Debian-specific.

share|improve this answer
    
I don't think anything has ever been more surprisingly difficult than trying to set up any decent TV-watching application under Ubuntu/Linux. –  nobar Mar 20 at 17:00
    
I finally got MythTV up and running (at least the basic functionality) with my HDHomeRun Connect with the help of this ~30 minute video walkthrough. –  nobar Mar 20 at 17:12
    
Had to use mythfrontend --geometry 1920x1080+0+0 (replace the first 0 with a horizontal position) to control which monitor MythTV displays on. –  nobar Mar 20 at 17:25
    
Fix aspect ratio under Setup->Appearance. It apparently couldn't determine the display aspect ratio on my system and defaulted to 4:3. This caused it to scale the HD image on one axis for reasons I haven't yet comprehended. –  nobar Mar 20 at 17:39
    
There are some other interesting options under Setup->Appearance. For example, you can uncheck Hide mouse cursor in MythTV which was a default feature that was contributing to my annoyance. –  nobar Mar 20 at 17:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.