Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently installed Ubuntu 14.04 from scratch, overwriting 13.10. Ever since then, I haven't been able to play audio in most desktop media applications: Spotify, Rhythmbox, Pithos, Banshee...all of them show that they're playing a song (including a libnotify popup), but no sound comes out, and the application's progress bar doesn't move. Web applications (flash, HTML5 in Firefox/Chrome) can still play audio just fine, and desktop applications that do not use indicator-sound (e.g., Audacity) can, too. The one indicator-sound application that I've found that can play audio is VLC.

ALSA info at http://www.alsa-project.org/db/?f=63b1c39b80f5baa1f37190eea3c4b38bfff322d6.

Any suggestions for how to fix this?

EDIT: Just to be perfectly clear, I do have audio in most applications (VLC, Firefox, Totem, Audacity, etc.). It's specific music applications that are affected. I think it might have something to do with gstreamer (although that wouldn't explain why Totem works).

share|improve this question
    
See if you can have sound in your guest account. If yes then try this: askubuntu.com/questions/201780/… –  Takkat Jun 2 at 18:18
    
The guest account does indeed have sound, but none of the steps there make a difference. –  duncanka Jun 3 at 1:10
    
PulseAudio is indeed starting, by the way. –  duncanka Jun 3 at 2:25

2 Answers 2

If you have sound in your guest account, then most likely you have accidentally done something wrong to the pulse audio configuration in your own account. Try removing (or renaming, just to be on the safe side) the pulse subdirectory of the .config directory of the account that has no audio:

cd ~/.config

mv pulse pulse-renamed

Then log out of your account, log in again, and you should have audio back.

share|improve this answer
    
I already tried that – that was one of the steps listed at askubuntu.com/questions/201780/…, all of which I tried. And as I've written in other comments, I do have audio. It's specific applications that don't work, and it's not just that I can't hear the audio – the applications don't even advance the scrubber. It's like they get stuck on the start of the stream and won't budge from there. (And no, it doesn't help to manually move around the scrubber.) –  duncanka Aug 8 at 15:07

Try in terminal (Ctrl+Alt+T):

sudo killall pulseaudio

sudo apt-get update

sudo apt-get install --reinstall pulseaudio

sudo service lightdm restart

or if didn't help

sudo shutdown -r now
share|improve this answer
    
No go. Tried purging PulseAudio, too. –  duncanka Jun 3 at 2:25
    
did you try to play music and run alsamixer in terminal to check if you haven't muted anything? –  JohnnyEnglish Jun 3 at 2:29
    
Yes. I tried all the steps listed at askubuntu.com/questions/201780/…. And as I said, web-based players work fine, as do some desktop apps. –  duncanka Jun 3 at 17:09
    
First of all go to system settings find sound there's an option you'll see test sound if it works then it's ok, there must be something's wrong with those apps, did you try to re-install those apps that don't have a sound using apt-get install --reinstall command? Did you check that sound is not muted inside an app itself by a chance? Did you try to install any new media player for example sudo apt-get install guayadeque to see if it produces sound? –  JohnnyEnglish Jun 4 at 17:26
    
As I wrote multiple times, sound works overall. Web players work fine, VLC works fine, Totem works fine. I've repeatedly tried purging and reinstalling individual application packages (rhythmbox, banshee, etc.), to no avail. –  duncanka Aug 8 at 3:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.