Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I am not able to play "Half-Life-2" on Steam + Ubuntu 14.04 . Error shown in message box on screen:

    Could not find required OpenGL entry pint 'glGetError'! Either your video card is unsupported, or your OpenGL driver needs to be updated.

I have a Dell Inspiron Laptop. My OS is Ubuntu 14.04 and my graphics card is AMD Radeon HD 8600M. I have installed AMD properietry Driver.

The partial output of "glxinfo" is as follows:

    name of display: :0
    libGL: screen 0 does not appear to be DRI3 capable
    libGL: pci id for fd 4: 8086:0a16, driver i965
    libGL: OpenDriver: trying /usr/lib/i386-linux-gnu/dri/tls/i965_dri.so
    libGL: OpenDriver: trying /usr/lib/i386-linux-gnu/dri/i965_dri.so
    libGL: Can't open configuration file /home/arushi/.drirc: No such file or directory.
    libGL error: failed to load driver: i965
    libGL: OpenDriver: trying /usr/lib/i386-linux-gnu/dri/tls/swrast_dri.so
    libGL: OpenDriver: trying /usr/lib/i386-linux-gnu/dri/swrast_dri.so
    libGL: driver does not expose __driDriverGetExtensions_swrast(): /usr/lib/i386- linux-gnu/dri/swrast_dri.so: undefined symbol: __driDriverGetExtensions_swrast
    libGL: Can't open configuration file /home/arushi/.drirc: No such file or directory.
    libGL: Can't open configuration file /home/arushi/.drirc: No such file or directory.
    libGL error: failed to load driver: swrast
    display: :0  screen: 0
    direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
share|improve this question

3 Answers 3

I found the solution to my problem. To get TF2 to work again all I had to do was remove the symbolic link that I made to get Skype working:

/usr/lib/i386-linux-gnu/mesa/libGL.so.1

The problem now is Skype doesn't work again. I guess I'll just have to remake the symbolic link whenever I want to use Skype until Canonical fixes the seg fault issue with Skype.

share|improve this answer
up vote 4 down vote accepted

After a lot of internet searches I have found the solution to this problem.

Please read the comment made on the SteamCommunity forum by Christian Günther.

I just followed these steps and rebooted the system:

sudo rm /usr/lib/i386-linux-gnu/libGL.so.1.2.0
sudo ln -s /usr/lib32/fglrx/fglrx-libGL.so.1.2 /usr/lib/i386-linux-gnu/mesa/libGL.so.1.2.0

Now Half Life is working properly on my system..!

share|improve this answer
    
Good to see that it was use full to write my solution down. :) –  cguenther Sep 22 '14 at 13:33

I know this is an old thread but removing / deleting this symlink is not a great answer at all. Many other applications depend on this file, although steam requires current drivers.

Please read my solution to this issue:

Ubuntu 14.04 “could not find required OpenGL entry point 'glGetError'!"

share|improve this answer
    
This was a workaround for a bug on Canonical's end that has since been fixed. This shouldn't be relevant anymore. –  KylePlusPlus Mar 5 at 21:48
    
Weird then. Because I had this issue 4 days ago? Great fix from their end then.. –  Schalk Mar 6 at 5:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.