Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Sony laptop and I want to turn keyboard back-light off. It doesn't have a shortcut function key for doing this on the keyboard . I can turn off it with VAIO Control Center in Windows but I don't know how can I turn it off in Ubuntu 14.04.

There isn't available to me: /sys/devices/platform/sony-laptop/kbd_backlight doesn't exist on my machine.

I have this folder /sys/devices/platform/sony-laptop/ and the ls command shown this result:

user@user-pc:/sys/devices/platform/sony-laptop$ ls
battery_care_health  battery_care_limiter  driver  modalias  power  subsystem  touchpad  uevent

there is three folder one power folder and two shortcut-ed folder driver , subsystem and five file contains battery_care_health , battery_care_limiter , modalias , touchpad and event

This is the output of running sudo modinfo sony-laptop:

filename:       /lib/modules/3.13.0-35-generic/kernel/drivers/platform/x86/sony-laptop.ko
version:        0.6
license:        GPL
description:    Sony laptop extras driver (SPIC and SNC ACPI device)
author:         Stelian Pop, Mattia Dongili
srcversion:     5C6E050349475558A231C59
alias:          acpi*:SNY6001:*
alias:          acpi*:SNY5001:*
depends:        
intree:         Y
vermagic:       3.13.0-35-generic SMP mod_unload modversions 
signer:         Magrathea: Glacier signing key
sig_key:        B1:41:4A:E9:6C:1B:0E:BB:7C:14:1F:A4:05:C1:F6:C9:8E:8A:66:F0
sig_hashalgo:   sha512
parm:           debug:set this to 1 (and RTFM) if you want to help the development of this driver (int)
parm:           no_spic:set this if you don't want to enable the SPIC device (int)
parm:           compat:set this if you want to enable backward compatibility mode (int)
parm:           mask:set this to the mask of event you want to enable (see doc) (ulong)
parm:           camera:set this to 1 to enable Motion Eye camera controls (only use it if you have a C1VE or C1VN model) (int)
parm:           minor:minor number of the misc device for the SPIC compatibility code, default is -1 (automatic) (int)
parm:           kbd_backlight:set this to 0 to disable keyboard backlight, 1 to enable it (default: no change from current value) (int)
parm:           kbd_backlight_timeout:meaningful values vary from 0 to 3 and their meaning depends on the model (default: no change from current value) (int)

With the suggested command:

sudo modprobe -r sony_laptop
sudo modprobe -v sony_laptop kbd_backlight=0

Output was:

insmod /lib/modules/3.13.0-35-generic/kernel/drivers/platform/x86/sony-laptop.ko kbd_backlight=0

It doesn't seem to affect the keyboard backlight.
And also trying this command:

sudo modprobe -v sony_laptop kbd_backlight_timeout=3 kbd_backlight=0

and doesn't seem to effect the keyboard backlight I also test it after restart laptop, And I didn't see any effect too.

Important : By default, keyboard backlight is off; when I press a key it turns on and after 15 seconds it turns off again. It's the same result on battery and AC power

I followed also http://ubuntuforums.org/showthread.php?t=2139597 and
Keyboard backlighting not working on a Vaio VPCSB11FX but didn't work so.

share|improve this question
    
Try this –  totti Jun 16 at 14:43
    
@totti I couldn't install nvidia-bl-dkms I get this error:E: Unable to locate package nvidia-bl-dkms –  KasiyA Jun 16 at 17:28
    
Seems like you might have already tried this, but create a file named sony-laptop.conf in /etc/modprobe.d. Add options sony-laptop kbd_backlight=0 to the file, save it and restart the computer. If it doesn't work, remove the file. –  Seth Jun 19 at 18:29
    
@Seth No, it doesn't work. Thanks –  KasiyA Jun 22 at 12:06
    
... after a restart modprobe stuff is automatically reset to the defaults. What I'm asking is, does the light switch off when you run the command individually or in combination WITHOUT rebooting. –  fossfreedom Jun 24 at 15:50

4 Answers 4

up vote 5 down vote accepted
+500

Replacement for old and obsolete answer

Update (8/27/2014): Bug was reported, and is available here. Current bug status is:
status:CONFIRMED
importance:MEDIUM
assigned to:UNASSIGNED

Through a chat with KasiyA and corroboration from the Ubuntu Linux developers, this problem is a bug. As such, unless a member on AU is an official kernel developer (Jon Skeet maybe?), this bug can not be solved.

I think that this should be reported in the proper area, which is here.

For the bug title, place the name of the kernel module (sony-laptop) and a brief description of the bug ("Laptop Keyboard Backlight not turning off")

For the content, describe the bug in its entirety. Describe what works and what doesn't. Also include the following resources:

  • This page. It contains information on what you tried so far.
  • The chat. This contains debugging info and some more things tried. The devs can sort through this.
  • The Patch(es). If a patch can be found (it was in this situation), make sure to include it. It will save the devs TONS of time. And, your bug gets solved faster.

Also, bugs are (usually) handled in order of importance. Make your bug sound important, but don't exaggerate.

When your bug is solved, BE HAPPY! You just made it into the Official Linux Kernel changelog!

Also: Make sure to follow any instructions on the bug reporting page. The more stuff you give the devs, the easier their jobs are, and the faster your bug is solved.


Old Post:
Try downloading the Vaio Control Center from SourceForge.

To install it, run the following steps:

  1. Open a terminal
  2. cd ~/Downloads
  3. mkdir ~/.VCC
  4. mv vaio-control-center-0.1.tar.bz2 ~/.VCC
  5. cd ~/.VCC
  6. tar -xjvf vaio-control-center-0.1.tar.bz2
  7. make -j12
  8. chmod +x vaio-control-center
  9. ./vaio-control-center

If you want, you can create a link to the control center onto your desktop. Simply make a .desktop entry pointing to ~/.VCC/vaio-control-center.

Once you are in the app, look for a backlight options menu and try adjusting that.

Note: For this to work, you MUST have QT Core and QT Dev installed!

Edit (inspired by comment by MGodby): Make sure you have qt4-qmake installed. Also make sure that the conf-file is in /usr/share/qt/mkspecs/linux-g++-64/qmake.conf. If need be, make a symlink to the proper location.

On a slightly unrelated note, have you tried using modprobe with sony-laptop instead of sony_laptop?

On a slightly less unrelated note, have you tried updating to the latest kernel?

share|improve this answer
    
I have reported it as a bug bugs.launchpad.net/ubuntu/+source/linux/+bug/1362046 –  KasiyA Aug 27 at 8:43
    
@KasiyA please make sure to check the bug page frequently. Users may post additional instructions and other things that need to be done. For instance, you are being prompted to run Apport currently. –  Whaaaaaat Aug 27 at 16:15
    
@KasiyA Can you test the upstream kernel? Comment 19 in the bugreport should help. –  Whaaaaaat Aug 27 at 21:13
    
I should not install that. –  KasiyA Aug 28 at 5:03
1  
@KasiyA There's always duck tape. –  Whaaaaaat Aug 28 at 6:20

How about this:

  1. Edit (or create) /etc/modprobe.d/options.conf
  2. Add options sony-laptop kbd_backlight=0 or 1
  3. Update intial ramdisk sudo update-initramfs -u
  4. Reboot

Source: http://ubuntuforums.org/showthread.php?t=1865782

share|improve this answer
    
NO, Did not work. –  KasiyA Aug 23 at 17:40
    
Okay. Atleast I tried. –  Parto Aug 23 at 17:49
    
Thank you for your attention to this matter. –  KasiyA Aug 23 at 18:00

Here is a tool I found trying to bring better support for viao F series

Here are the install instructions

git clone https://code.google.com/p/vaio-f11-linux.control-center/
cd vaio-f11-linux.control-center
./compile
./run
share|improve this answer
    
root@user-pc:/home/user/vaio-f11-linux.control-center# ./compile I get this error: -su: ./compile: Permission denied –  KasiyA Aug 27 at 11:47
    
Dont run as root in your home folder ? –  mark kirby Aug 27 at 11:48
    
This error: ./compile: line 5: syntax error near unexpected token 'newline' ./compile: line 5: '<!DOCTYPE html>' –  KasiyA Aug 27 at 11:50
    
sudo chmod 777 +x /home/user/vaio-f11-linux.control-center –  mark kirby Aug 27 at 11:51
    
chmod: cannot access '+x’: No such file or directory –  KasiyA Aug 27 at 11:52

Try this:

echo 0 > /sys/devices/platform/sony-laptop/kbd_backlight
share|improve this answer
    
Please first read my question. kbd_backlight doesn't exist on my machine. –  KasiyA Aug 20 at 20:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.