Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I know this is a silly question. I got a 2.5" hard disk drive that I use for my laptop. It has problems, so I plugged it out and attached it into a hard disk case and connected the hard disk to my computer using USB.

When I hit the super key and write "disks", the "Disks" utility shows me the hard disk. It says:

Hard Disk

JMicron USB to ATA/ATAPI Bridge

However, when I click onto it to show the mount point and etc, I can't see anything.

It doesn't tell me about the size and contents, but it says the device is /dev/sdc. In my first try, the Disks utility told me that the size is 2.2TB - which is weird because it writes 500GB on the hard disk.

After this, I Google'd and tried to find a way to mount this.

I executed this command:

sudo fdisk -l

I couldn't see the hard disk there, but since the Disks utility told me it's /dev/sdc, I tried mounting it like this:

sudo mkdir /media/e_test
sudo mount -t ntfs-3g /dev/sdc /media/e_test

Those didn't work, so I tried:

sudo mount -t ntfs /dev/sdc /media/e_test

Didn't work either. And lastly,

sudo mount -t vfat -o /dev/sdc /media/e_test

And it didn't work either.

How can I recover the files in this hard disk?

Thank you very much.

share|improve this question
    
Any chance of plugging it into a windows machine? If that fails then the disk is most likely unrecoverable. –  Virusboy Jun 2 at 7:30
    
@Virusboy I plugged it into a Windows machine. It said the driver installed successfully. However, it wasn't in the Computer window. I right clicked to Computer, then clicked Manage, and chose Storage. It said that I have to initialize the hard disk. Something about MBR is missing. I clicked "initialize MBR...", but the application said the drive is not initialized. –  user1652575 Jun 2 at 8:25
    
Once "weird" disk sizes start to show up, it is time to throw the drive away. Last week, I had a server claim a few thousand Petabytes capacity on a faulty 1.5TB disk ... –  Stefan Schmiedl Jun 2 at 8:40
    
@StefanSchmiedl I gave the hard disk back to my boss. He didn't like the situation, but it's not my job and this is all I know about this subject. So, yeah, it's better to throw that little piece of hard disk. Thanks for the feedback. :) –  user1652575 Jun 2 at 12:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.