Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My USB keyboard isn't working in Ubuntu 14.04, but also didn't work in 13.10. I upgraded today in the hope that the issue would be resolved, but it wasn't. The keyboard works in BIOS and GRUB but stops working when I reach the login screen.

It is detected by the system, but just doesn't work.

Output of lsusb:

Bus 002 Device 002: ID 0846:9011 NetGear, Inc. WNDA3100v2 802.11abgn [Broadcom BCM4323]
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 002: ID 1532:000d Razer USA, Ltd 
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 002: ID 060b:2231 Solid Year KSK-6001 UELX Keyboard
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

I added:

  • hid
  • usbhid
  • hid_generic
  • ohci_pci

To /etc/initramfs-tools/modules and did update-initramfs -u, but that didn't work.

Output of xinput:

Virtual core pointer                        id=2    [master pointer  (3)]
↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
↳ Razer Razer Diamondback 3G                id=9    [slave  pointer  (2)]
Virtual core keyboard                       id=3    [master keyboard (2)]
↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
↳ Power Button                              id=6    [slave  keyboard (3)]
↳ Power Button                              id=7    [slave  keyboard (3)]
↳ KB USB Keyboard                           id=8    [slave  keyboard (3)]

Output of dmesg:

[  670.988075] usb 8-2: USB disconnect, device number 7
[  711.860023] usb 8-2: new low-speed USB device number 8 using uhci_hcd
[  712.125038] usb 8-2: New USB device found, idVendor=060b, idProduct=2231
[  712.125042] usb 8-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[  712.125045] usb 8-2: Product: USB Keyboard
[  712.125048] usb 8-2: Manufacturer: KB
[  712.187568] input: KB USB Keyboard as /devices/pci0000:00/0000:00:1d.2/usb8/8-2/8-2:1.0/input/input34
[  712.187709] hid-generic 0003:060B:2231.001D: input,hidraw0: USB HID v1.11 Keyboard [KB USB Keyboard] on usb-0000:00:1d.2-2/input0
[  712.269196] hid (null): usage index exceeded
[  712.269577] hid-generic 0003:060B:2231.001E: usage index exceeded
[  712.269581] hid-generic 0003:060B:2231.001E: item 0 2 2 2 parsing failed
[  712.269591] hid-generic: probe of 0003:060B:2231.001E failed with error -22
share|improve this question
    
can you get the output of xinput, and can you use the on-screen keyboard? –  Tim Jun 1 at 20:46
    
Output of xinput added to question. I can use the on-screen keyboard. –  Steven Crossan Jun 2 at 11:18
    
Can you post the end of the output of dmesg when you plug in your printer? It will be a few lines like "new high-speed USB device...". Are you using a USB3 port or have some USB 3 ports on the system? –  bain Jun 2 at 16:47
    
It sounds like this keyboard may just be incompatible with some systems, see Linux comptability with a KSK-6001 Keysonic Keyboard and Keysonic usb did not work. That bug report indicates it could be a bug or hardware problem: "generic-usb: probe of 0003:060:2231.0008 failed with error -22". What does your dmesg say? –  bain Jun 2 at 16:53
    
Output of dmesg added to question. I don't have any USB3 ports on the system, only USB1/2. It looks like you're right, I may have to go and buy another keyboard. Is it possible to change to module being used in: [ 711.860023] usb 8-2: new low-speed USB device number 8 using uhci_hcd Could it be an issue with uhci_hcd? –  Steven Crossan Jun 2 at 19:37

1 Answer 1

According to this post, the keyboard does work under Linux - but you have to press ctrl+shift+alt+n when you log in to disable the keyboard's anti-ghosting features.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.