Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.
  1. I am not sure since when the filesystem on my digital audio player has been changed to be read-only. I cannot copy files into it or remove files on it.

    Are there some possible reasons for the player's file system to change the permission of its file system?

  2. I tried chmod:

    $ sudo chmod a+rw SGTL\ MSCN/ 
    chomd: changing permissions of `SGTL MSCN/': Read-only file system
    

    where "SGTL MSCN" is the mounted point of the digital audio player.

    I was wondering how to make it writable?

Thanks and regards!

share|improve this question
    
Thanks! I already tried that, and same output. I will add this to my post. –  Tim Jun 7 '11 at 20:03
    
Could you also add brand of the player? :) searching 'SGTL MSN' actually ONLY brings up this topic :D If you are really unlucky it's the device that's bugged: as a last(!) resort reset the player. But only when you do not get any good anwsers soon(ish) :) –  Rinzwind Jun 7 '11 at 20:11
    
My bad. The name is "SGTL MSCN". –  Tim Jun 7 '11 at 20:32
    
what are the mount options mount| grep SGTL ? –  Emmanuel Dec 2 '13 at 16:54

4 Answers 4

up vote 33 down vote accepted

If a filesystem has been mounted read-only, chmod will not work since it's a write operation too.

Try remounting it read-write:

sudo mount -o remount,rw '/media/SGTL MSCN'

If the device has a write lock on it (like SD memory cards), you need to turn it off. Hardware locks cannot be disabled by software. Note that the write lock on SD memory cards is located from the sight you see the letters near the up left corner and it looks like a very small switch.

Some filesystem drivers may also not support write operations, this is the case with the older NTFS module supported by Linux. For NTFS filesystems, be sure to use the ntfs-3g driver which should be picked automatically nowadays. If not, you can force the driver with something like:

sudo mount -t ntfs-3g -o uid=$(id -u) /dev/sdb1 /mnt/

(where /dev/sdb1 has to be substituted for your block device and /mnt/ for your destination)

share|improve this answer
    
I'm trying this, and getting "DRIVE not mounted or bad option." –  mattshepherd Apr 15 '13 at 22:22
    
@mattshepherd if you have whitespace in the file name, you need to surround it with quotes. –  Lekensteyn Apr 16 '13 at 8:23
    
No, no whitespaces. I, er, wound up doing it in Windows. –  mattshepherd Apr 16 '13 at 22:50
    
it doesn't work without root, and in companies always root isn't given to developers –  Shirish Herwade May 30 at 6:19
    
@ShirishHerwade In those companies, there is likely a policy restricting the use of external USB drives. –  Lekensteyn May 30 at 8:55

I had this problem occur on several USB sticks. Each time I searched for an answer and tried various suggestions, including using Terminal to run commands, reformatting on both Linux and Windows machines, etc. All to no avail.

It happened to me again today so again I went looking to see if I could find a solution. I tried the things here, but they didn't work.

Out of desperation I again went to Disk Utility. I unmounted the drive and then hit "Format" on the partition portion, not the drive portion - USB only had the single partition. This time it WORKED!!!!. Then I went to the drive portion and again reformatted the single partition as a master boot drive and monkeyed a bit more with it.

The upshot it, I'm now able to read and write to the drive again.

I don't know if I just got lucky this time or not. But it is working again.

share|improve this answer

If the USB stick is mounted as read-only. Go to Disk Utility and unmount the disk. Then click on Check Filesystem if there are no problems remount the disk. After mounting the disk it should work correctly, at least that is how I solved this problem.

share|improve this answer
    
Sounds like it doesnt do anything, but this fixed it for me –  Karthik T Aug 8 at 15:15

In case it is a fixed drive and not a removable drive, you can add the entry permanently.

sudo vi /etc/fstab

Add an entry in the following format:

<file-system> <mount-point> <type> <options> <dump> <pass>

And then do:

mount -a
share|improve this answer

protected by jokerdino Dec 2 '13 at 17:54

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.