Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have added the following to my sources.list:

deb http://ppa.launchpad.net/kubuntu-ppa/experimental/ubuntu/ lucid main

Unfortunately, whenever I do a sudo apt-get update, the repository is ignored. At least that's what I think IGN means in the following output.

Does anyone know how to force the use of a repository?

Here's the part where it says "ign":

Ign http://ppa.launchpad.net/kubuntu-ppa/experimental/ubuntu/ lucid/main Translation-en_US

share|improve this question
    
I've always thought that it means "Ignored because the repository information is up-to-date". You can check whether a repository is used by running apt-cache policy. Optionally add a package name of a package from the PPA. –  Lekensteyn Jun 7 '11 at 19:53
    
@Lekensteyn, that's the main reason I asked. I'm not sure. –  jrg Jun 7 '11 at 19:55

1 Answer 1

up vote 6 down vote accepted

Ign repo_link means that the diff did not return any package updates so it was ignored.

You can force it by doing: apt-get clean && apt-get update

You can also optionally pin the repo: vim /etc/apt/preferences.d/kubuntu-ppa-pin-900

Package: *
Pin: release o=LP-PPA-kubuntu-ppa,n=experimental
Pin-Priority: 900

900 puts it at the highest, anything less than 500 will make it less important than main repos.

share|improve this answer
    
Can you answer in general cases, How I can figure out Pin information o=something n=something? for example, deb http://download.virtualbox.org/virtualbox/debian precise contrib –  Smile.Hunter Dec 23 '12 at 1:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.