Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've installed Dropbox (as per the instructions supplied in Dropbox's Home Page and a personal blog I found browsing about the subject), but still no success in forcing autostart (only for my user) on dropboxd. I've tried adding an autostart file in:

But no success so far... I have to start it manually. I don't want to edit the file in:

/etc/xdg/lxsession/Lubuntu/autostart

The file plainly states:

~/.dropbox-dist/dropboxd

as I have understood, would add autostart for Dropbox for all users...

Any ideas about what went wrong?


Edit: both the links mentioned above seem non-functional.

share|improve this question
1  
What about adding Dropbox to the Startup Applications list? –  nitstorm Jun 8 '11 at 0:28

3 Answers 3

That is different solution, which works in Ubuntu 11.10:

You will need start-up script. Save it to /etc/init.d/dropbox

groupadd dropbox
usermod -aG dropbox root
chmod +x /etc/init.d/dropbox
update-rc.d dropbox defaults

Change root in second code line above with your needs. Make sure you don't forget the -a switch in usermod - especially when you use

Run Dropbox manually for first time

/root/.dropbox-dist/dropbox

Change command above with your environment.

Copy URL it gives you (do not stop or interrupt program, just copy URL). Paste the URL to the Browser, confirm password. You will see Dropbox confirmation, that it is connected. Now you can interrupt Dropbox by Ctrl+C. Reboot to try autostart. If it not starts, run Dropbox manually once again and look up for any messages or errors.

share|improve this answer

For per-user autostart, use the ~/.config/lxsession/<profile>/autostart file. For more info see the LXDE wiki

share|improve this answer
    
That is the one I'm using right now, but it doesn't work, however, another option has been suggested for this query... –  Gibarian Jun 8 '11 at 12:42

solved here: http://ubuntuforums.org/showpost.php?p=11108807&postcount=8

In order to get Dropbox to autostart at logon, I did this: made a new file in my autostart folder here:

/home/GUS/.config/autostart

(you should change GUS to whatever your own username is) Call the file Dropbox.desktop Open it in your text editor and paste these lines, again changing GUS to your username in the line that starts with "Exec":

[Desktop Entry]
Encoding=UTF-8
Name=Dropbox
Comment=RunDropbox
Icon=/usr/share/icons/elementary/panel/22/dropboxstatus-logo.svg
Exec=bash /home/GUS/.dropbox-dist/dropboxd
Terminal=false
Type=Application

Save it. Logout. Login. Be happy.

By the way, in order to get dropbox installed, I followed the instructions here: http://www.omgubuntu.co.uk/2010/04/how-to-install-dropbox-in-lubuntu

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.