Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

The menu bar and Unity launcher have disappeared in Ubuntu 14.04. Also cannot access the terminal via Ctrl+Alt+T.
I have tried every solution for this issue that I can find, from re-installing unity and compiz to resetting Unity and everything. I've gone into the compiz manager and reactivated Unity.
Nothing has worked.
When trying to reset Unity, or do anything with it really, I get this message

(process:6332): dconf-WARNING **: failed to commit changes to dconf: Could not connect: Connection refused

EDIT: Installed 14.04 a day ago. The issue happened after a reboot. After installing virtual Box

share|improve this question
possible duplicate of Unity doesn't load, no Launcher, no Dash appears – karel Aug 29 '14 at 11:15
The exact same thing happened to me. Afraid to attempt re-installing virtualbox. Ever figure out why this happened? – Jay Soyer Oct 25 '14 at 3:26
Running export DISPLAY=:0 on a separate tty, following the procedure outlined in… to set the DBUS_SESSION_BUS_ADDRESS variable and finally running dconf reset -f /org/compiz/ did the trick for me. – Janaka Bandara Nov 27 '14 at 1:13
I'm also missing the launcher & menu bar, software-center is uninstalled, and I cannot open a terminal either through Ctrl-Alt-T nor Ctrl-Alt-F1-6. By booting into single-user mode (rEFInd), I automatically became root (without needing a password). This allowed me to create a new user and add them to the sudo group. I've now logged into the new account (where the GUI is fine) and have used su to get into my original account. I'm wondering if its possible to copy the GUI setup from the new user to my old one? If so, what should I copy? – gone Jul 31 at 17:18
Same problem after installing Virtual Box... Solution export DISPLAY=:0 sudo dconf reset -f /org/compiz/ setsid unity – Djomla Oct 19 at 9:39

1 Answer 1


Enter the following commands:- Ctrl+Alt+F1 login there by user name and password

try sudo service lightdm restart

If lightdm fails to get back at normal :-

then Enter:- sudo apt-get update

sudo apt-get install --reinstall ubuntu-desktop
sudo apt-get install unity
share|improve this answer
Warning! This terminates the session. – Dror Feb 17 at 12:30
I read the warning too late, god damn :D – red Apr 1 at 7:55
Same problem as OP, but when I C-A-F1 (-F6) I get a blank screen. (No terminal.) What other options do I have? – gone Jul 31 at 15:23
Ha, ha... Yeah, too late, it terminated my session, though my VPN connection is up. So, it does not free everything. – nephewtom Oct 5 at 8:58

protected by Community Aug 29 '14 at 11:50

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.