Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Updated my system manually with apt-get dist-upgrade. After reboot system gets stuck on black loading screen with text Xubuntu 12.04 and white dots under it. Tried to boot with older kernels but results remained the same. Booted into recovery mode. I can connect to network and mount all partitions. Tried startx command which loaded default desktop. If I try "resume normal boot" option it says: initctl: Event failed which suggests a problem with video driver, but it was not updated. This error does not occur when simply booting, then it's just stuck on loading screen.

Pulled the update log:

Contents of /var/log/apt/history.log

Start-Date: 2014-06-01 10:39:16 Commandline: aptdaemon role='role-upgrade-system' sender=':1.47' Upgrade:

libcupsppdc1:amd64 (1.5.3-0ubuntu8.2, 1.5.3-0ubuntu8.3),

libcupsimage2:amd64 (1.5.3-0ubuntu8.2, 1.5.3-0ubuntu8.3),

libcupscgi1:amd64 (1.5.3-0ubuntu8.2, 1.5.3-0ubuntu8.3),

libcupsdriver1:amd64 (1.5.3-0ubuntu8.2, 1.5.3-0ubuntu8.3),

cups-client:amd64 (1.5.3-0ubuntu8.2, 1.5.3-0ubuntu8.3),

cups-ppdc:amd64 (1.5.3-0ubuntu8.2, 1.5.3-0ubuntu8.3),

cups-common:amd64 (1.5.3-0ubuntu8.2, 1.5.3-0ubuntu8.3),

libcups2:amd64 (1.5.3-0ubuntu8.2, 1.5.3-0ubuntu8.3),

libcups2:i386 (1.5.3-0ubuntu8.2, 1.5.3-0ubuntu8.3),

cups:amd64 (1.5.3-0ubuntu8.2, 1.5.3-0ubuntu8.3),

cups-bsd:amd64 (1.5.3-0ubuntu8.2, 1.5.3-0ubuntu8.3),

cherrytree:amd64 (0.33.1-1~ppa1~precise1, 0.33.4-1~ppa1~precise1),

linux-libc-dev:amd64 (3.2.0-61.93, 3.2.0-63.95),

libcupsmime1:amd64 (1.5.3-0ubuntu8.2, 1.5.3-0ubuntu8.3),

linux-generic-lts-raring:amd64 (3.8.0.39.39, 3.8.0.41.41)

End-Date: 2014-06-01 10:39:31

Start-Date: 2014-06-01 10:58:07 Commandline: apt-get dist-upgrade Install:

linux-headers-3.8.0-41:amd64 (3.8.0-41.60~precise1, automatic),

linux-headers-3.8.0-41-generic:amd64 (3.8.0-41.60~precise1, automatic),

linux-image-3.8.0-41-generic:amd64 (3.8.0-41.60~precise1)

Upgrade: linux-image-generic-lts-raring:amd64 (3.8.0.39.39, 3.8.0.41.41), linux-headers-generic-lts-raring:amd64 (3.8.0.39.39, 3.8.0.41.41) End-Date: 2014-06-01 10:59:17

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.