Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I get the following error when i try to mount my external hard drive.

UNABLE TO MOUNT
Error mounting /dev/sdc1 at /media/khalibloo/Khalibloo2: Command-line `mount -t "ntfs" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000,dmask=0077,fmask=0177" "/dev/sdc1" "/media/khalibloo/Khalibloo2"' exited with non-zero exit status 13: ntfs_attr_pread_i: ntfs_pread failed: Input/output error
Failed to read of MFT, mft=6 count=1 br=-1: Input/output error
Failed to open inode FILE_Bitmap: Input/output error
Failed to mount '/dev/sdc1': Input/output error
NTFS is either inconsistent, or there is a hardware fault, or it's a SoftRAID/FakeRAID hardware. In the first case run chkdsk /f on Windows then reboot into Windows twice. The usage of the /f parameter is very important! If the device is a SoftRAID/FakeRAID then frst activate it and mount a different device under the /dev/mapper/ directory, (e.g. /dev/mapper/nvidia_eahaabcc1). Please see the 'dmraid' documentation for more details.

It doesn't mount on windows either:

I/O Device error

it's an ntfs hard drive with a single partition

Of course, i tried chkdsk /f, it reported several file segments as unreadable, but didn't say whether it fixed them or not (apparently not). also tried with the /b flag.

ntfsfix reported the volume as corrupt.

TestDisk was able to fix a small error with the partition table by adding the "80" flag for the active (only) partition. TestDisk also confirmed that the boot sector was fine and it matched the backup. However, when attempting to repair the MFT, it couldn't read the MFT. It also couldn't list the files on the hard drive. It says file system may be damaged.

Active@ also shows that MFT is missing or corrupt.

I tried replacing the USB cable. Didn't change anything. I tried to update the driver. Windows reported that it was already up to date. Yes, the driver was enabled.

So how do I fix the file system? or the MFT? or the I/O device error?

UPDATE: I noticed that with each try, chkdsk /f goes a bit further, so I kept trying until i got to a point where it says

    Insufficient disk space to hotfix unreadable system file 4

Since I can't access the files on the drive, there's no way to free up any space. So I thought that perhaps I could format the drive partially to free up some space, and retry chkdsk /f. Do you think that could work? Or will it just cause more problems to interrupt a format process?

share|improve this question

1 Answer 1

Here is a link to another resource that may be of help to you, in particular the section on trouble-shooting connectivity. :
https://help.ubuntu.com/community/Mount/USB

It offers several options for narrowing down the issue, and potential causes, include interfering services, an unclean log-file, and improper user permissions, to name a few.

And this link to another post on the forum, goes through a process to repair an NTFS 500gb external hard drive filesystem, similar to your issue. They suggest running chkdsk /f on the drive in question on a Windows OS (as NTFS is primarily a Windows file-system, by my understanding). :
http://ubuntuforums.org/showthread.php?t=1605850

Another post in the forum for resolving issues with NTFS externals and Ubuntu. :
How can I use Ubuntu to rescue files from an NTFS drive?

Amended: according to this, some alternatives include Active@ UNERASER for DOS or Active@ File Recovery for Windows for serious MFT damage. Now, they are third-party software, so be fore-warned. I've never used the mentioned software, and make no claims to their functionality, but they are options you could explore.

Alternative:
Should the above not help you, this may help you. It is a link to a resource I suggested in another answer about backing up filesystem volumes, so that they can be reformatted. May be of use to you.

If none of the above solutions resolve you issue, this contains, among other things, links to commercial software you could explore as options. I've never used the listed software in those links, but I believe they are worth looking into, at least. If no free software has resolved your issue yet, then sometimes, you get what you pay for.

share|improve this answer
    
thanks, but from what i gather, MTP is a protocol for phones, right? This is a 500GB external hard drive. A USB mass storage device and i've been using it for months now (both on ubuntu and windows). here's the product page toshiba.co.uk/hard-drives/portable/store-basics/hdtb105ek3aa –  Khalifa Abbas Lame Jun 1 at 12:06
    
I see, I misread your question, please see my amended answer. –  SonOfEntropy Jun 1 at 17:38
    
Thanks for the links. I've already tried all the relevant steps from those posts. I've tried chkdsk /f, ntfsfix, etc. The second link you gave came close to my issue, but it seems his MFT was undamaged. Mine is damaged, and i don't know how to restore from the MFT mirror. –  Khalifa Abbas Lame Jun 1 at 21:26
    
See the Amended section in my answer, offering two alternatives for file recovery. –  SonOfEntropy Jun 1 at 21:44
    
Ok, I tried Active@ file recovery. Couldn't even recover a single file. However, i just discovered that with each attempt, chkdsk /f goes a bit further. I'll keep trying; perhaps it will eventually fix the issues. –  Khalifa Abbas Lame Jun 2 at 9:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.