Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've followed this guide to put Bumblebee to work. Everything was working perfect and I was happy playing my Steam games using primusrun to run them. But after today's update, which updated something related to NVIDIA, Bumblebee is not working anymore:

$ primusrun glxgears
2014/06/01 02:36:36 socat[4154] E connect(3, AF=1 "/var/run/bumblebee.socket", 27): No such file or directory
primus: fatal: failed to connect to Bumblebee daemon: No such file or directory

I'm using Ubuntu 14.04, I have an optimus notebook with a dedicated Nvidia GeForce 730M and an integrated Intel card. Could someone help me, please?

share|improve this question

2 Answers 2

up vote 2 down vote accepted

I managed to solve the problem by reinstalling bbswitch-dkms. I guess that when a NVIDIA related package was updated in the main repositories, something on the kernel was changed. So, reinstalling bbswitch-dkms fixed the primusrun problem. All I had to do was to run this command:

sudo apt-get install --reinstall bbswitch-dkms

I hope it helps someone who is having the same problem I had. Now primusrun works again. Thanks for the help!

share|improve this answer

Based on your information, after looking over the link you supplied, and doing some digging of my own, I've found this link that should get you going.
Excerpt from link:

SOLUTION: Replace all the *-bumblebee packages by * packages, this means enabling multiverse repo and drawing all of it from official repos instead of anything from AUR. Examples: nvidia instead of nvidia-bumblebee, primus instead of primus-git, nvidia-utils instead of nvidia-utils-bumblebee, lib32-nvidia-utils instead of lib32-nvidia-utils-bumblebee. Some time ago the 'official' instructions were exactly the other way round, but it seems this was now completely reverted.

Source link: https://bbs.archlinux.org/viewtopic.php?id=162219

Hope this helps, good luck.

share|improve this answer
    
I appreciate your help, but I never installed these packages in the first place. I installed bumblebee, bumblebee-nvidia and primus from ppa:bumblebee/stable and I installed nvidia-331 and nvidia-settings-331 from ppa:xorg-edgers/ppa. Anyway, I managed to fix the problem by reinstalling bbswitch-dkms. I'll post a more detailed answer to tell what I did. –  renatov Jun 1 at 15:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.