Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have been trying to get this to work for several days. I have googled until I can't google anymore.....

I have Ubuntu 10.04 64 bit with Virtualbox Ver. 3.2.8 installed. I have a windows xp pro guest. I am running Rosettas stone in the guest. Everything works great except the mic.

The guest audio is:

Host Driver:PulseAudio Controller:ICH AC97

This works well in Lucid. In XP it's as if the os doesn't know how to use the mic. I see it in the xp sound app. It doesn't work but it's listed as intel integrated sudio. When I run sound recorder , I click on record and the bar/slider that indicates time recording doesn't move.

Are there any settings in VB that I need to modify to get this to work?

I tried getting rosetta stone to work in wine but had no luck.

share|improve this question
add comment

closed as too localized by Luis Alvarado Mar 14 '13 at 17:19

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

2 Answers

Do this: Go left click on sound indicator on Ubuntu and chose Sound Preferences In the Input tab on conector chose your Mic (for me work Microphone 2) Then go to System > Administration > User and Groups Click on Manage Groups, scoll down on vboxusers select hem with 1 left click an then click on Properties and check your user name box and click OK Open VirtualBox, turn on your XP Guest, right click on sound icon (in your XP Guest), chose Open Volume Control. In the windows that apear, go to Options and click on Properties Scroll down and check Microphone box. and then click OK

Or look to this Screencast: http://screenr.com/qIG

For my works fine but because i use screenr.com that blow my demonstration :D

share|improve this answer
add comment

Make sure that /etc/group/vboxusers includes your user name. Run this in terminal and look for the vboxusers entry

$ grep vboxusers /etc/group
vboxusers:x:111:alice,bill

If your user name isn't in there then add it:

sudo gpasswd -a bill vboxusers

Replace bill with your username.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.